0

I'm using ipmiutil.exe to reset the IPMI watchdog on my 64-bit Supermicro server (X11SBA-F) running Windows 10 Enterprise IOT, but it's not working returning the following error:

ipmiutil wdt -r
ipmiutil wdt ver 3.13
-- BMC version 1.53, IPMI version 2.0
wdt data: 00 00 00 00 00 00 00 00
Watchdog timer is stopped for use with reserved. Logging
               pretimeout is 0 seconds, pre-action is None
               timeout is 0 seconds, counter is 0 seconds
               action is No action
Resetting watchdog timer ...
reset_wdt: ret = 128
wdt data: 00 00 00 00 00 00 00 00
Watchdog timer is stopped for use with reserved. Logging
               pretimeout is 0 seconds, pre-action is None
               timeout is 0 seconds, counter is 0 seconds
               action is No action

ipmiutil wdt, Invalid Session Handle or Empty Buffer 

I installed Intel IMB Driver downloaded from this link and tried both 32-bit and 64-bit versions of ipmiutil.exe but to no avail. Has anyone faced a similar error?

UPDATE 1:

I tried disabling Windows IPMI driver ipmidrv.sys but it don't help. On further tests, I noticed that after enabling IPMI watchdog through BIOS, it still shows "Watchdog timer is stopped for use with reserved." when I issue "ipmiutil wdt". It appears that ipmituil is unable to obtain the correct setting on the watchdog.

Here's some more information:

ipmiutil health
ipmiutil health ver 3.13
BMC manufacturer  = 002a7c (SuperMicro), product = 0891
BMC version       = 1.53, IPMI v2.0
BIOS Version      = 1.1a
IPMI driver type  = 1        (imb)
Power State       = 00       (S0: working)
Selftest status   = 0055     (OK)
Chassis Status    = 21 00 40 00 (on, see below)
        chassis_power       = on
        pwr_restore_policy  = last_state
        chassis_intrusion   = inactive
        front_panel_lockout = inactive
        drive_fault         = false
        cooling_fan_fault   = false
Power On Hours    = 18 hours (0 days)
BMC LAN Channels  = 1
ipmiutil health, completed successfully
0

I found the solution. The problem had nothing to do with intel imb driver or 32bit/64bit. Enabling watchdog in bios is not sufficient. I had to enable it using ipmiutil:

ipmiutil wdt -e
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.