0

I have 4 identical computers with fresh install of Windows 10 1809 pro x64 french, workgroup, no antivirus, no WSUS. The first were cloned 3 times, i made a sysprep after each clone.

I want to install a software (don't matted which software is) but block at prerequisite check : .Net Framework 2.0 not installed.

I check the checkbox on Additional features : ".Net 2.0 3.0 3.5...", install using Windows Update, seems success.

After a reboot, the software refuses to install, same reason.

In Additional features, .Net2/3/3.5 is now checked. So I uncheck and apply. I got error 0x80004005. .Net2/3/3.5 still checked.

In HKLM/Software/Microsoft/.NETFramework/ i have version v2.0.... + v4.0... only, not "v3.0".

In the folder C:\Windows\Microsoft.NET\Framework64, it seems all versions are here.

Using DISM /enable-feature /featurename:Netfx3 (/online, using original ISO...) => success (about 5 sec); but DISM /disable-feature /featurename:Netfx3 => error 0x80004005, same as GUI. Didn't found relevant info in DISM.log.

SFC /scannow => no error found

DISM /checkhealth => no error found

Using original online or offline setup of .Net 2.0 or 3.5 => Windows 10 ask "install prerequisites" or "ignore".

  • Install prerequisites immediately return "success, may restart the program...".
  • Ignore do nothing.

In eventviewer, each time i use DISM command, i get :

  • "System restore" error 0x80070422
  • "Windows Error Reporting" information about CBS Package Servicing failure on Microsoft-Windows-Foundation-Package, but P6=80004005 : Same error as DISM.

DISM /get-features lists a lot of things, NetFX3 "activated", no trace of Microsoft-Windows-Foundation-Package.

Versions:

  • Windows: 10.0.17763.437
  • DISM: 10.0.17763.1
  • CBS(?): 10.0.17763.402

Any help appreciated

2
  • It's likely that the installer isn't checking appropriately for .Net 2.0. Try copying the program from another computer and running it without installing it.
    – longneck
    May 7 '19 at 18:30
  • The program is protected, it's impossible. However i will try to run another app requiring .Net 2.0. I used "Asoft .Net Version Detector", which says 2.0 3.0 3.5 are installed. That's don't explain why i cannot uninstall .Net 2.0/3.0/3.5.
    – Baud
    May 8 '19 at 10:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.