2

I need to establish a connection from my Windows 10 laptop to a shared remote desktop through a remote LINUX server. My colleagues are all using LINUX and can't provide Windows help.

I've searched several help sites, which helped me establish an SSH connection to the LINUX server using Putty. But I'm still unable to figure out how to join the shared Remote Desktop session.

I was provided the following information (some of the details have been obfuscated for security purposes):

"I've created an account for you on our VPN system. It provides remote access to our network. You will only need it to create a tunnel to the development system.

user name: abc pw: xxxxxxxxx

In Linux you would do the following to setup a tunnel:
ssh www.xxx.com -p 1234 -l abc -N -f -L3389:99.999.999.999:3389

On Putty there should be the equivalent.

The idea is that you are establishing an ssh session with www.xxxxx.com:1234 using the credentials noted above.

On top of this ssh session, you are also establishing a tunnel (the -L part) that redirects localhost:3389 through the ssh session and out to 99.999.999.999:3389 which is the system.

Once the tunnel is established, use an RDP client to connect to localhost:3389 to access the system. Since it is being routed through the network, it will be allowed in on the side."

Again, I was also informed that the desktop to which I am trying to connect is in a shared remote session – all remote users share this connection to the desktop.

The ssh seems to be working. A terminal window opens to the LINUX machine and asks for login credentials. I am able to login with the credentials I was provided, above.

As for the tunnel, I’m not sure it is working. When I try to establish the Remote Desktop connection (using localhost:3389 via Windows Remote Desktop on my laptop) I always get an error. Usually, it says I am already in a remote session and can’t establish a new one. I’m not sure how to ensure Remote Desktop is attempting to join a shared session, rather than create a new one.

Can you help?

2

Your Windows system is probably already using port 3389 because it has RDP enabled locally. So use a different port number that is unused on your local system.

ssh -L33890:192.0.2.5:3389 ...

In your RDP client connect to localhost:33890. By using localhost:3389, you are almost certainly trying to use RDP to have the computer connect to itself.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.