I enable ipfw rules on my mail server. After some time server collapsed. In /var/log/messages is nothing information of my damage. But when I connected monitor, I saw some troubles with swap

swap_pager: indefinite wait buffer

Then I entered command dmesg and saw:

total configured swap (1048576 pages) exceeds maximum recommended amount (980224 pages).
 increase kern.maxswzone or reduce amount of swap.

What I must do? Increase kern.maxswzone? Or increase RAM? Or increase swap?

Сan this problem be due ipfw? Before ipfw everything worked. RAM on server - 512 Mb.

  • Please edit your post to include your machine architecture and version of FreeBSD. uname -a will give you that. My first suggestion would be to increase the RAM. What is the approximate level of complexity of your firewall rules ... what's the output of ipfw list | wc -l? The swap_pager error message suggests you may have hardware problems in your disk subsystem ... failing disk, bad sectors in the swap partition, bad cabling? – Jim L. May 14 '19 at 22:58
  • See Swap "kern.maxswzone" Help "... They recommended setting it to 0 to let it choose it's own amount automatically. ... Note that this is only if you were using amd64. If you are using i386 then I think it needs setting properly. With i386 I think it has issues using approx 4GB or more swap." – Vladimir Botka May 15 '19 at 6:19
  • Result of uname -a FreeBSD mail.domain.com 10.3-RELEASE FreeBSD 10.3-RELEASE #0 r297264: Fri Mar 25 03:51:29 UTC 2016 root@releng1.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC i386 – Artem Khmil May 15 '19 at 6:51
  • my firewall rules ru.stackoverflow.com/q/980247/308859 – Artem Khmil May 15 '19 at 6:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.