-2

When I execute nmap -sn 192.168.1.0/24, it takes 12 seconds to find 256 hosts but when I execute nmap -sS 192.168.1.0/24, it takes forever. Why is this happening?

I cannot see what I did wrong. Maybe I wrote my address wrong or something. I am using Kali Linux and the nmap that came installed. It is a virtual machine on a laptop and the connection is wireless.

I was thinking that it could be because of the connection. Should I try making a hotspot with my phone and connecting some stuff to it and then trying?

closed as off-topic by Wesley, womble May 15 at 23:00

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions on Server Fault must be about managing information technology systems in a business environment. Home and end-user computing questions may be asked on Super User, and questions about development, testing and development tools may be asked on Stack Overflow." – Wesley, womble
If this question can be reworded to fit the rules in the help center, please edit the question.

2

The -sn option pings each target host, but does not do any additional port scanning. Twelve seconds for 256 hosts seems about right.

The -sS option sends a Syn packet to each of 65,535 ports on each target host, and then checks for a response. Even though it can do this pretty quickly, it's still doing thousands to tens of thousands of times more activity than the ping-only scan that -sn does.

From Nmap's options summary:

...

-sn: Ping Scan - disable port scan

...

-sS/sT/sA/sW/sM: TCP SYN/Connect()/ACK/Window/Maimon scans

  • i found someting.serverfault.com/questions/216938/… here you can see tat he has the same problem that all the hosts come up. A guy in the comment said it is a firewall problem and i think he is right becuase i use a VM but he doesnt give any answer – Andrei Marin May 15 at 19:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.