0

I have a problem i just finish and upload my site but he not work with safari got white page i check log

[Thu May 16 07:56:17.534196 2019] [authz_core:debug] [pid 5671] mod_authz_core.c(820): [client 172.31.33.224:4894] AH01626: authorization result of Require all granted: granted
[Thu May 16 07:56:17.534240 2019] [authz_core:debug] [pid 5671] mod_authz_core.c(820): [client 172.31.33.224:4894] AH01626: authorization result of <RequireAny>: granted
[Thu May 16 07:56:17.534288 2019] [authz_core:debug] [pid 5671] mod_authz_core.c(820): [client 172.31.33.224:4894] AH01626: authorization result of Require all granted: granted
[Thu May 16 07:56:17.534293 2019] [authz_core:debug] [pid 5671] mod_authz_core.c(820): [client 172.31.33.224:4894] AH01626: authorization result of <RequireAny>: granted
[Thu May 16 07:56:17.534309 2019] [proxy:debug] [pid 5671] mod_proxy.c(1254): [client 172.31.33.224:4894] AH01143: Running scheme unix handler (attempt 0)
[Thu May 16 07:56:17.534315 2019] [proxy_ajp:debug] [pid 5671] mod_proxy_ajp.c(743): [client 172.31.33.224:4894] AH00894: declining URL fcgi://localhost/var/www/html/public/index.php
[Thu May 16 07:56:17.534318 2019] [proxy_fcgi:debug] [pid 5671] mod_proxy_fcgi.c(1021): [client 172.31.33.224:4894] AH01076: url: fcgi://localhost/var/www/html/public/index.php proxyname: (null) proxyport: 0
[Thu May 16 07:56:17.534322 2019] [proxy_fcgi:debug] [pid 5671] mod_proxy_fcgi.c(1028): [client 172.31.33.224:4894] AH01078: serving URL fcgi://localhost/var/www/html/public/index.php
[Thu May 16 07:56:17.534327 2019] [proxy:debug] [pid 5671] proxy_util.c(2326): AH00942: FCGI: has acquired connection for (*)
[Thu May 16 07:56:17.534343 2019] [proxy:debug] [pid 5671] proxy_util.c(2379): [client 172.31.33.224:4894] AH00944: connecting fcgi://localhost/var/www/html/public/index.php to localhost:8000
[Thu May 16 07:56:17.534347 2019] [proxy:debug] [pid 5671] proxy_util.c(2416): [client 172.31.33.224:4894] AH02545: fcgi: has determined UDS as /run/php-fpm/www.sock
[Thu May 16 07:56:17.534420 2019] [proxy:debug] [pid 5671] proxy_util.c(2588): [client 172.31.33.224:4894] AH00947: connected /var/www/html/public/index.php to httpd-UDS:0
[Thu May 16 07:56:17.534441 2019] [proxy:debug] [pid 5671] proxy_util.c(2959): AH02823: FCGI: connection established with Unix domain socket /run/php-fpm/www.sock (*)
[Thu May 16 07:56:17.638434 2019] [proxy:debug] [pid 5671] proxy_util.c(2341): AH00943: FCGI: has released connection for (*)

So i search on google and see problem is config vhost

My initial vhost look like that :

<VirtualHost *:80>

ServerName mysite.com

   RewriteEngine On

   RewriteCond %{HTTP_HOST} !^www\. [NC]

   RewriteRule !/elbcheck.html https://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

   RewriteCond %{HTTP:X-Forwarded-Proto} !https

   RewriteCond %{HTTPS} off

   RewriteRule !/elbcheck.html https://%{HTTP_HOST}%{REQUEST_URI} [L,R]

     DocumentRoot /var/www/html/public

    <Directory /var/www/html/public>

Require all granted

        AllowOverride None

        Order Allow,Deny

        Allow from All

FallbackResource /index.php

        <IfModule mod_rewrite.c>

            Options -MultiViews

            RewriteEngine On

            RewriteCond %{REQUEST_FILENAME} !-f

            RewriteRule ^(.*)$ index.php [QSA,L]

        </IfModule>

    </Directory>

    # uncomment the following lines if you install assets as symlinks

    # or run into problems when compiling LESS/Sass/CoffeeScript assets

    <Directory /var/www/html>

         Options FollowSymlinks

    </Directory>

    # optionally disable the RewriteEngine for the asset directories

    # which will allow apache to simply reply with a 404 when files are

    # not found instead of passing the request into the full symfony stack

    <Directory /var/www/html/public/bundles>

        FallbackResource disabled

    </Directory>

    ErrorLog /var/log/error-mysite-web.log

    LogLevel debug

    CustomLog /var/log/access-mysite-web.log combined

</VirtualHost>

I try to change for :

<VirtualHost *:80>

ServerName mysite.com
ServerAlias www.mysite.com

   RewriteEngine On

   RewriteCond %{HTTP_HOST} !^www\. [NC]

   RewriteRule !/elbcheck.html https://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

   RewriteCond %{HTTP:X-Forwarded-Proto} !https

   RewriteCond %{HTTPS} off

   RewriteRule !/elbcheck.html https://%{HTTP_HOST}%{REQUEST_URI} [L,R]


<FilesMatch \.php$>
        #SetHandler proxy:fcgi://127.0.0.1:9000
        # for Unix sockets, Apache 2.4.10 or higher
        SetHandler proxy:unix:/run/php-fpm/www.sock|fcgi://localhost
    </FilesMatch>

     DocumentRoot /var/www/html/public

    <Directory /var/www/html/public>

Require all granted

        AllowOverride None

        Order Allow,Deny

        Allow from All

FallbackResource /index.php

        <IfModule mod_rewrite.c>

            Options -MultiViews

            RewriteEngine On

            RewriteCond %{REQUEST_FILENAME} !-f

            RewriteRule ^(.*)$ index.php [QSA,L]

        </IfModule>

    </Directory>

    # uncomment the following lines if you install assets as symlinks

    # or run into problems when compiling LESS/Sass/CoffeeScript assets

    <Directory /var/www/html>

         Options FollowSymlinks

    </Directory>

    # optionally disable the RewriteEngine for the asset directories

    # which will allow apache to simply reply with a 404 when files are

    # not found instead of passing the request into the full symfony stack

    <Directory /var/www/html/public/bundles>

        FallbackResource disabled

    </Directory>

    ErrorLog /var/log/error-mysite-web.log

    LogLevel debug

    CustomLog /var/log/access-mysite-web.log combined

</VirtualHost>

But got error white page again and now

[Thu May 16 09:13:57.216483 2019] [authz_core:debug] [pid 9224] mod_authz_core.c(820): [client 172.31.22.222:57982] AH01626: authorization result of Require all granted: granted, referer: https://www.example.com/fr/
[Thu May 16 09:13:57.216532 2019] [authz_core:debug] [pid 9224] mod_authz_core.c(820): [client 172.31.22.222:57982] AH01626: authorization result of <RequireAny>: granted, referer: https://www.example.com/fr/
[Thu May 16 09:13:57.216599 2019] [authz_core:debug] [pid 9224] mod_authz_core.c(820): [client 172.31.22.222:57982] AH01626: authorization result of Require all granted: granted, referer: https://www.example.com/fr/
[Thu May 16 09:13:57.216604 2019] [authz_core:debug] [pid 9224] mod_authz_core.c(820): [client 172.31.22.222:57982] AH01626: authorization result of <RequireAny>: granted, referer: https://www.example.com/fr/
[Thu May 16 09:13:57.216622 2019] [proxy:debug] [pid 9224] mod_proxy.c(1254): [client 172.31.22.222:57982] AH01143: Running scheme unix handler (attempt 0), referer: https://www.example.com/fr/
[Thu May 16 09:13:57.216631 2019] [proxy_ajp:debug] [pid 9224] mod_proxy_ajp.c(743): [client 172.31.22.222:57982] AH00894: declining URL fcgi://localhost/var/www/html/public/index.php, referer: https://www.example.com/fr/
[Thu May 16 09:13:57.216639 2019] [proxy_fcgi:debug] [pid 9224] mod_proxy_fcgi.c(1021): [client 172.31.22.222:57982] AH01076: url: fcgi://localhost/var/www/html/public/index.php proxyname: (null) proxyport: 0, referer: https://www.example.com/fr/
[Thu May 16 09:13:57.216647 2019] [proxy_fcgi:debug] [pid 9224] mod_proxy_fcgi.c(1028): [client 172.31.22.222:57982] AH01078: serving URL fcgi://localhost/var/www/html/public/index.php, referer: https://www.example.com/fr/
[Thu May 16 09:13:57.216667 2019] [proxy:debug] [pid 9224] proxy_util.c(2326): AH00942: FCGI: has acquired connection for (*)
[Thu May 16 09:13:57.216672 2019] [proxy:debug] [pid 9224] proxy_util.c(2379): [client 172.31.22.222:57982] AH00944: connecting fcgi://localhost/var/www/html/public/index.php to localhost:8000, referer: https://www.example.com/fr/
[Thu May 16 09:13:57.216676 2019] [proxy:debug] [pid 9224] proxy_util.c(2416): [client 172.31.22.222:57982] AH02545: fcgi: has determined UDS as /run/php-fpm/www.sock, referer: https://www.example.com/fr/
[Thu May 16 09:13:57.216758 2019] [proxy:debug] [pid 9224] proxy_util.c(2588): [client 172.31.22.222:57982] AH00947: connected /var/www/html/public/index.php to httpd-UDS:0, referer: https://www.example.com/fr/
[Thu May 16 09:13:57.216792 2019] [proxy:debug] [pid 9224] proxy_util.c(2959): AH02823: FCGI: connection established with Unix domain socket /run/php-fpm/www.sock (*)
[Thu May 16 09:13:57.648620 2019] [proxy:debug] [pid 9224] proxy_util.c(2341): AH00943: FCGI: has released connection for (*)

I dont understand my apache version is 2.4.39 and php 7.2.16(fpm-cgi)

with conf fpm [www] user = apache group = apache listen = /run/php-fpm/www.sock

Can you help me thanks

  • "and see problem is config vhost" - What was the "problem" with the vhost? "not work with safari" - Did this problem only affect Safari? Or any browser? – DocRoot May 16 at 9:12
  • @DocRoot i answer you can look Thanks – Jonny May 16 at 9:19
  • Could it be simply that the Safari browser cached some earlier response? Does its console say anything? Does calling /index.php explicitly work? – user188737 May 16 at 9:35
  • @DocRoot Only safari got white page, site work on others browser but got error in logs too so i really don t understand – Jonny May 16 at 9:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.