0

I have three WINSRV2012R2:

  1. x.x.x.120 SERVER00.DOMAIN.COM Aliase "SITE.DOMAIN.COM"
  2. x.x.x.121 SERVER01.DOMAIN.COM
  3. x.x.x.122 SERVER02.DOMAIN.COM

nslookup "SITE.DOMAIN.COM" returns:

  • server DOMAINCONTROLER.DOMAIN.COM
  • address x.x.x.11
  • /
  • name SERVER00.DOMAIN.COM
  • Address x.x.x.120
  • Aliases: SITE.DOMAIN.COM

1 - IIS Server Farm Balance with anonymous authentication 2nd and 3rd windows authentication providers NTLM and Negotiate

htt*/site.domain.com/ or htt*/x.x.x.120/ forwards me to ONE of web servers 2 or 3

I need to autologin site.

Mozilla uses its own settings (about:config-> network.automatic-ntlm-auth.trusted-uris we add string: "site.domain.com,x.x.x.120") Works FINE, users login automatic to sites htt*/site.domain.com/ or htt*/x.x.x.120/

Chrome, IE(InternetExplorer) and edge use security settings (Internet options(security tab)) We add in the Local intranet list htt*/site.domain.com/ and htt*/x.x.x.120/

Auto login to htt*/x.x.x.120/ in Chrome, IE, EDGE works FINE

Auto login to htt*/site.domain.com/ in IE, EDGE works FINE

BUT in Chrome htt*/site.domain.com/ IT'S ASKS for LOGIN and PASSWORD, but only once (untill browser restart)

If in the file c:\windows\system32\drivers\etc\hosts add string "x.x.x.120 site.domain.com" Chrome autologin work FINE.

Was tested on some chrome versions (71,72,73,49). On chrome wersion 49 shows follows error: ERR_INVALID_AUTH_CREDENTIALS

Need help solving the issue. To make chrome without string in the hosts send credentials automaticly.

What i have been trying:

  • Turn off Negotiate provider (Chrome OK, site not works)
  • Tried to start Chrome with params –auth-server-whitelist=”MYIISSERVER.DOMAIN.COM” –auth-negotiate-delegatewhitelist=”MYIISSERVER.DOMAIN.COM” –auth-schemes=”digest,ntlm,negotiate” (Does not work)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.