0

I'm using OpenLDAP on Ubuntu 16.04.

My endgame is to use an LDAP directory as basis for a Samba 4 NT domain (legacy reasons).

When I run slapcat, I see all data that I have entered into the LDAP.

However, when I run slapd and execute

ldapsearch -H ldapi:/// -Y EXTERNAL -b "cn=config" -LLL -Q "olcDatabase=*" 

my search yields "no such object (32)".

Why is that so? The configuration directory is clearly there under /etc/ldap/slapd.d/ and is being considered when running slapd.

I suspect it has something to do with authentication.

0

Whether you can access a LDAP server is a matter of correct access control.

Normally you have to use authz-regexp directive to map the local user (e.g. root) to a authz-DN which is then granted access by and access to directive(s) (see slapd.conf static configuration).

See also: OpenLDAP Admin Guide -- Access Control

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.