0

I'm using google cloud platform, and want to install hyper v on windows 2016 vm but i keep getting this message :hyper v cannot be installed : the processor doesn’t have required virtualization capabilities. what can i do ?

  • I expect you will not be able to install Hyper-V on a public cloud instance. Your public cloud VMs are already virtual servers, so you don't want to add another virtual layer on top of them. You should be able to use containers on your public cloud VMs, though. – Todd Wilcox May 16 at 20:05
  • Google does seem to have documentation about enabling nested virtualization. No idea if it works for Windows platforms, since they mention KVM. cloud.google.com/compute/docs/instances/… Not really familiar with Google Cloud, and if this will cost more or whatever. Might need to consider other platforms. – Zoredache May 16 at 20:06
2

As the documentation states, Google Cloud only supports KVM-based (nested) virtualization.

Nested virtualization is supported only for KVM-based hypervisors running on Linux instances. Hyper-V, ESX, and Xen hypervisors are not supported.

And by not supported it is meant that it simply does not work and cannot be made to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.