0

I am testing pppd dial in to a 4g network. I want to see my side sending auth request to the server. Hence I added 'auth' and 'require-pap' in my local pppd config. But whatever I tried, it seemed that my pppd keep not sending ConfReq with the desired options. It, however, always send [LCP ConfReq id=0x1 ].

How do I understand this and can I command the pppd to send out auth request?

pppd config

15200
connect '/usr/sbin/chat -v -E -f /etc/ppp/peers/modem1_connect.chat'
lock
local
proxyarp
noipx
allow-ip *
debug
auth
require-pap
pap-max-authreq 10
pap-restart 3
pap-timeout 0
maxfail 5
maxconnect 0
chap-interval 0
chap-max-challenge 10
chap-restart 3
lcp-echo-failure 0
lcp-echo-interval 0
lcp-max-configure 10
lcp-max-failure 10
lcp-max-terminate 3
lcp-restart 3
noccp
vj-max-slots 8
deflate 0
bsdcomp 0
connect-delay 1000
holdoff 0
ipcp-accept-local
ipcp-accept-remote
ipcp-max-configure 10
ipcp-max-failure 10
ipcp-max-terminate 10
ipcp-restart 3
noipv6
defaultroute

The pppd logs:

pppd: pppd 2.4.7 started by root, uid 0
chat: timeout set to 5 seconds
chat: abort on (BUSY)
chat: abort on (NO CARRIER)
chat: abort on (ERROR)
chat: abort on (NO DIALTONE)
chat: send (AT^M)
chat: expect (OK)
chat: AT^M^M
chat: OK
chat:  -- got it
chat: send (ATZ^M)
chat: expect (OK)
chat: ^M
chat: ATZ^M^M
chat: OK
chat:  -- got it
chat: send (ATE1^M)
chat: expect (OK)
chat: ^M
chat: ^M
chat: OK
chat:  -- got it
chat: send (AT+CPIN=0000^M)
chat: expect (ERROR)
chat: ^M
chat: AT+CPIN=0000^M^M
chat: ERROR
chat:  -- got it
chat: send (^M)
chat: send (AT+CGDCONT=1,"IP","honeywell001.shapn"^M)
chat: expect (OK)
chat: ^M
chat: ^MAT+CGDCONT=1,"IP","honeywell001.shapn"^M^M
chat: OK
chat:  -- got it
chat: send (ATDT*99***1#^M)
chat: timeout set to 15 seconds
chat: expect (CONNECT)
chat: ^M
chat: ATDT*99***1#^M^M
chat: CONNECT
chat:  -- got it
pppd: Script /usr/sbin/chat -v -E -f /etc/ppp/peers/modem1_connect.chat finished (pid 31057), status = 0x0
pppd: Serial connection established.
pppd: using channel 11
pppd: Using interface ppp0
pppd: Connect: ppp0 <--> /dev/ttyACM0
pppd: sent [LCP ConfReq id=0x1 <mru 1400> <asyncmap 0x0> <magic 0x68c09343> <pcomp> <accomp>]
pppd: rcvd [LCP ConfReq id=0x1 <asyncmap 0x0> <auth pap> <magic 0xb9107ff4> <pcomp> <accomp>]
pppd: sent [LCP ConfAck id=0x1 <asyncmap 0x0> <auth pap> <magic 0xb9107ff4> <pcomp> <accomp>]
pppd: rcvd [LCP ConfAck id=0x1 <mru 1400> <asyncmap 0x0> <magic 0x68c09343> <pcomp> <accomp>]
pppd: sent [PAP AuthReq id=0x1 user="Honeywell001" password=<hidden>]
pppd: rcvd [PAP AuthAck id=0x1 ""]
pppd: PAP authentication succeeded
pppd: sent [IPCP ConfReq id=0x1 <compress VJ 07 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
pppd: rcvd [IPCP ConfReq id=0x1]
pppd: sent [IPCP ConfNak id=0x1 <addr 0.0.0.0>]
pppd: rcvd [IPCP ConfRej id=0x1 <compress VJ 07 01> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
pppd: sent [IPCP ConfReq id=0x2 <addr 0.0.0.0>]
pppd: rcvd [IPCP ConfReq id=0x2 <addr 10.10.1.22>]
pppd: sent [IPCP ConfAck id=0x2 <addr 10.10.1.22>]
pppd: rcvd [IPCP ConfNak id=0x2 <addr 10.10.1.22>]
pppd: sent [IPCP ConfReq id=0x3 <addr 10.10.1.22>]
pppd: rcvd [IPCP ConfAck id=0x3 <addr 10.10.1.22>]
pppd: Cannot determine ethernet address for proxy ARP
pppd: local  IP address 10.10.1.22
pppd: remote IP address 10.10.1.22
pppd: Script /etc/ppp/ip-up started (pid 31067)
pppd: Script /etc/ppp/ip-up finished (pid 31067), status = 0x0

Thanks! -woody

  • Add debug option into the pppd configuration file and paste the output into the question. Also, have you added the auth option into the pppd config? – Anton Danilov May 23 '19 at 9:58
  • Hi Anton, I added the logs and configs to the original post. – Woody Wu May 23 '19 at 12:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.