1

I am aware of the many people with basically the same question as this one. However, I am apparently unable to understand the answers and thousands of blog entries on the web that try to explain the situation for me.

I have a server running Ubuntu 18.04 hosted by 1and1 with Apache 2.4.29. The only purpose of this server is to host a wordpress. The wordpress is only and reachable, however I need to specify the www tag in front of my url which I want to avoid. Here is my current redirect situation:

#### Working:

$ curl -I https://www.mywebsite.org
HTTP/1.1 200 OK
Date: Fri, 24 May 2019 07:36:42 GMT
Server: Apache/2.4.29 (Ubuntu)
Link: <https://www.mywebsite.org/wp-json/>; rel="https://api.w.org/"
Content-Type: text/html; charset=UTF-8



$ curl -I http://www.mywebsite.org
HTTP/1.1 301 Moved Permanently
Date: Fri, 24 May 2019 07:37:23 GMT
Server: Apache/2.4.29 (Ubuntu)
Location: https://www.mywebsite.org/
Content-Type: text/html; charset=iso-8859-1

$ curl -I www.mywebsite.org
HTTP/1.1 301 Moved Permanently
Date: Fri, 24 May 2019 07:36:56 GMT
Server: Apache/2.4.29 (Ubuntu)
Location: https://www.mywebsite.org/
Content-Type: text/html; charset=iso-8859-1

####### Not working:

$ curl -I mywebsite.org
curl: (6) Could not resolve host: mywebsite.org

$ curl -I https://mywebsite.org
curl: (6) Could not resolve host: mywebsite.org

$ curl -I http://mywebsite.org
curl: (6) Could not resolve host: mywebsite.org

I tried various redirect commands but I think what stops me from finding a solution is the fact that I do not know where to put the redirect information:

  • Inside /etc/apache2/sites-available/ ? If so, in which of these files: 000-default.conf, default-ssl.conf, wordpress.conf?
  • Inside /var/www/.htaccess?
  • Inside /var/www/wordpress/.htacces?
  • Somewhere completely different?

I tried out a lot of things but due to my lack of skills this is mostly copy pasting and I ended up in a mess. Not smart at all and I am very ashamed but for what it's worth here is:

000-default.conf

<VirtualHost *:80>
RewriteEngine On
RewriteCond %{HTTPS} off [OR]
RewriteCond %{HTTP_HOST} !^www\. [NC]
RewriteCond %{HTTP_HOST} ^(?:www\.)?(.+)$ [NC]
RewriteRule ^ https://www.%1%{REQUEST_URI} [L,NE,R=301]
</VirtualHost *:80>

<Directory /var/www/wordpress>
  Options Indexes FollowSymLinks MultiViews
  AllowOverride All
  Order allow,deny
  allow from all
  # Uncomment this directive is you want to see apache2's
  # default start page (in /apache2-default) when you go to /
  #RedirectMatch ^/$ /apache2-default/
</Directory>

default-ssl.conf

<IfModule mod_rewrite.c>
    RewriteEngine On

    RewriteCond %{HTTPS}        =off   [OR]
    RewriteCond %{HTTP_HOST}    !^mywebsite\.org$
    RewriteRule ^(.*)$          "https://www.mywebsite.org/$1" [R=301,L]

    # remaining htaccess mod_rewrite CODE for WordPress
</IfModule>

<VirtualHost *:80>
    ServerName mywebsite.org
    ServerAlias www.mywebsite.org
    Redirect permanent / https://www.mywebsite.org/
</VirtualHost>
#<VirtualHost *:80>
#   ServerName www.mywebsite.org
#   ServerAlias mywebsite.org
#   Redirect permanent / https://www.mywebsite.org/
#</VirtualHost>
<IfModule mod_ssl.c>
    <VirtualHost _default_:443>
        ServerAdmin webmaster@localhost
        ServerName mywebsite.org
        ServerAlias www.mywebsite.org

        DocumentRoot /var/www/wordpress

        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf

        #   SSL Engine Switch:
        #   Enable/Disable SSL for this virtual host.
        SSLEngine on

        #   A self-signed (snakeoil) certificate can be created by installing
        #   the ssl-cert package. See
        #   /usr/share/doc/apache2/README.Debian.gz for more info.
        #   If both key and certificate are stored in the same file, only the
        #   SSLCertificateFile directive is needed.
        SSLCertificateFile  /etc/ssl/certs/mywebsite.org_ssl_certificate.cer
        SSLCACertificateFile    /etc/ssl/certs/mywebsite.org_ssl_certificate_INTERMEDIATE.cer
        SSLCertificateKeyFile /etc/ssl/private/_.mywebsite.org_private_key.key

        #   Server Certificate Chain:
        #   Point SSLCertificateChainFile at a file containing the
        #   concatenation of PEM encoded CA certificates which form the
        #   certificate chain for the server certificate. Alternatively
        #   the referenced file can be the same as SSLCertificateFile
        #   when the CA certificates are directly appended to the server
        #   certificate for convinience.
        #SSLCertificateChainFile /etc/apache2/ssl.crt/server-ca.crt

        #   Certificate Authority (CA):
        #   Set the CA certificate verification path where to find CA
        #   certificates for client authentication or alternatively one
        #   huge file containing all of them (file must be PEM encoded)
        #   Note: Inside SSLCACertificatePath you need hash symlinks
        #        to point to the certificate files. Use the provided
        #        Makefile to update the hash symlinks after changes.
        #SSLCACertificatePath /etc/ssl/certs/
        #SSLCACertificateFile /etc/apache2/ssl.crt/ca-bundle.crt

        #   Certificate Revocation Lists (CRL):
        #   Set the CA revocation path where to find CA CRLs for client
        #   authentication or alternatively one huge file containing all
        #   of them (file must be PEM encoded)
        #   Note: Inside SSLCARevocationPath you need hash symlinks
        #        to point to the certificate files. Use the provided
        #        Makefile to update the hash symlinks after changes.
        #SSLCARevocationPath /etc/apache2/ssl.crl/
        #SSLCARevocationFile /etc/apache2/ssl.crl/ca-bundle.crl

        #   Client Authentication (Type):
        #   Client certificate verification type and depth.  Types are
        #   none, optional, require and optional_no_ca.  Depth is a
        #   number which specifies how deeply to verify the certificate
        #   issuer chain before deciding the certificate is not valid.
        #SSLVerifyClient require
        #SSLVerifyDepth  10

        #   SSL Engine Options:
        #   Set various options for the SSL engine.
        #   o FakeBasicAuth:
        #    Translate the client X.509 into a Basic Authorisation.  This means that
        #    the standard Auth/DBMAuth methods can be used for access control.  The
        #    user name is the `one line' version of the client's X.509 certificate.
        #    Note that no password is obtained from the user. Every entry in the user
        #    file needs this password: `xxj31ZMTZzkVA'.
        #   o ExportCertData:
        #    This exports two additional environment variables: SSL_CLIENT_CERT and
        #    SSL_SERVER_CERT. These contain the PEM-encoded certificates of the
        #    server (always existing) and the client (only existing when client
        #    authentication is used). This can be used to import the certificates
        #    into CGI scripts.
        #   o StdEnvVars:
        #    This exports the standard SSL/TLS related `SSL_*' environment variables.
        #    Per default this exportation is switched off for performance reasons,
        #    because the extraction step is an expensive operation and is usually
        #    useless for serving static content. So one usually enables the
        #    exportation for CGI and SSI requests only.
        #   o OptRenegotiate:
        #    This enables optimized SSL connection renegotiation handling when SSL
        #    directives are used in per-directory context.
        #SSLOptions +FakeBasicAuth +ExportCertData +StrictRequire
        <FilesMatch "\.(cgi|shtml|phtml|php)$">
                SSLOptions +StdEnvVars
        </FilesMatch>
        <Directory /usr/lib/cgi-bin>
                SSLOptions +StdEnvVars
        </Directory>

        <Directory /var/www/wordpress/>
                AllowOverride All
        </Directory>

        #   SSL Protocol Adjustments:
        #   The safe and default but still SSL/TLS standard compliant shutdown
        #   approach is that mod_ssl sends the close notify alert but doesn't wait for
        #   the close notify alert from client. When you need a different shutdown
        #   approach you can use one of the following variables:
        #   o ssl-unclean-shutdown:
        #    This forces an unclean shutdown when the connection is closed, i.e. no
        #    SSL close notify alert is send or allowed to received.  This violates
        #    the SSL/TLS standard but is needed for some brain-dead browsers. Use
        #    this when you receive I/O errors because of the standard approach where
        #    mod_ssl sends the close notify alert.
        #   o ssl-accurate-shutdown:
        #    This forces an accurate shutdown when the connection is closed, i.e. a
        #    SSL close notify alert is send and mod_ssl waits for the close notify
        #    alert of the client. This is 100% SSL/TLS standard compliant, but in
        #    practice often causes hanging connections with brain-dead browsers. Use
        #    this only for browsers where you know that their SSL implementation
        #    works correctly.
        #   Notice: Most problems of broken clients are also related to the HTTP
        #   keep-alive facility, so you usually additionally want to disable
        #   keep-alive for those clients, too. Use variable "nokeepalive" for this.
        #   Similarly, one has to force some clients to use HTTP/1.0 to workaround
        #   their broken HTTP/1.1 implementation. Use variables "downgrade-1.0" and
        #   "force-response-1.0" for this.
        # BrowserMatch "MSIE [2-6]" \
        #       nokeepalive ssl-unclean-shutdown \
        #       downgrade-1.0 force-response-1.0

    </VirtualHost>
</IfModule>

and wordpress.conf

<VirtualHost *:80>
    # The ServerName directive sets the request scheme, hostname and port that
    # the server uses to identify itself. This is used when creating
    # redirection URLs. In the context of virtual hosts, the ServerName
    # specifies what hostname must appear in the request's Host: header to
    # match this virtual host. For the default virtual host (this file) this
    # value is not decisive as it is used as a last resort host regardless.
    # However, you must set it for any further virtual host explicitly.
    ServerName 12.345.678.910
    ServerAlias 12.345.678.910

    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/wordpress

    # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

And here is /var/www/.htaccess

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{HTTPS} off [OR]
RewriteCond %{HTTP_HOST} !^www\. [NC]
RewriteCond %{HTTP_HOST} ^(?:www\.)?(.+)$ [NC]
RewriteRule ^ https://www.%1%{REQUEST_URI} [L,NE,R=301]
</IfModule>

I know this is a mess but is there any way to fix it?

10
curl: (6) Could not resolve host: mywebsite.org
          ^^^^^^^^^^^^^^^^^^^^^^

You have a DNS problem: www.mywebsite.org has an associated address in the DNS, mywebsite.org does not. Therefore, a HTTP request to http://mywebsite.org/ does not even reach your server, because that name cannot be resolved.

  • 1
    I am even more ashamed but happy that your post allowed me to solve the problem. I set up a redirect for mywebsite.org to www.mywebsite.org via the 1and1 admin interface and it works. Thank you so much! – k1next May 24 at 8:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.