-3

Error with a virtualized Windows Server 2016 client: Step "FTP Server" [1 of 1] failed: Login denied: Access denied: 530, who can help me.

1

Initially, check the FTP logs, /var/log/messages to find more details on why “FTP access denied 530” error occurs.This will give you clues like incorrect username, password, IP blocks, etc.

Based on the exact errors in the log, the fix differs. Take the necessary steps to fix it. Let’s check the fix for each of them.

  1. User permission denial

Fixing involves correcting the user permissions. In vsftpd server, we solve this issue by setting userlist_deny to NO in /etc/vsftpd/user_list. After that, we assign ‘allowed users’ in file /etc/vsftpd/user_list. Then we put the ‘not allowed users’ in /etc/vsftpd/ftpusers file too.

  1. Server authentication failure

Here, we suggest to authenticate to FTP server by using encrypted authentication. For this, you have to enable SSL in the FTP configuration settings.

  1. Login authentication failure

To fix this error, we help user to configure the FTP client setting with correct host address, username, and password. Also, we ensure that the username and password are given correctly.

  1. IP address denial

Obviously, to fix 530 errors due to IP block, we need to unblock IP address on the server. In cPanel servers, we can do this from ConfigServer Security & Firewall. There will be an unblock icon next to the blocked IP address. Simply clicking the icon unblocks the IP in the firewall.

Or if server uses iptables to block IP address, we unblock it from the command line itself.

Regards, Akshay

-1

No offence, but this is 2019 not 1972 (yes, FTP is very old). Please consider useing something more modern than FTP like SCP/SFTP.

  • This is pure opinion. The poster may have reasons to use FTP. – Daniel K May 25 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.