4

I am working on an arcade machine and it cannot be updated unfortunately. A drive has corrupted data on it and in order to delete it I need to re-partition that drive. (I know it's the data and not the drive because I have used dd to clone the partition onto another drive and the data can still not be removed with rm -rf /folder)

In order to fix this I need to do mkfs.xfs but I need to set the version. When just using mkfs.xfs it sets it to 5 automatically.

Reading though the documentation on mkfs.xfs I see no way to change the version. https://www.systutorials.com/docs/linux/man/8-mkfs.xfs/

I am looking any solutions, I can use slax, ubuntu or redhat to solve this. (I currently have machines with all 3)

xfs_db> version

[0x20a4+0x0] = V4,NLINK,ALIGN,DIRV2

xfs_info

https://i.imgur.com/WYMLKJh.png

Linux Kernal is 2.4.23

This machine also cannot use SATA because it does not have SATA drivers. If anyone knows how to manually install those, that would also be a big help.


UPDATE

I found a version of SLAX that is 6.1.2. It also does not have SATA Support, but the biggest issue is when I use fdisk and mkfs.xfs on this version then the UBUNTU can (newest version) can no longer read the partition type of the disk, but... it can read the partition type of the disk straight from the arcade machine.

UPDATE 2

Ubuntu 10.04 is quite easy to find, Ubuntu still hosts it. You can find an older version and use this to get it to format drives to XFS V4 but... for my project its still not working.

  • 2
    Exactly how ancient is the OS? And what is the OS? – Michael Hampton May 25 at 6:27
  • Some version of linux. Kernel... 2.4.23 something. Its for an In the Groove arcade machine. I checked everywhere a brand new should be and all I can find is the kernel. – Case May 25 at 7:03
  • Sadly it doesn't even have SATA support. – Case May 25 at 7:13
  • can you paste complete output of xfs_db> version and xfs_info <mount point> and your kernel version where you are trying? – asktyagi May 25 at 10:39
  • 1
    Most likely you'll need to go way back and find a contemporary version of Linux. Assuming the old kernel doesn't understand a modern XFS filesystem. – Michael Hampton May 25 at 23:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.