3

I have downloaded ceph-ansible to install ceph for an evaluation and I ran on an error with package dependencies and I can't find anything about how to fix this using either ceph-ansible or yum.

The error I got using ceph-ansible is below:

Tuesday 28 May 2019  14:48:06 -0300 (0:00:00.292)       0:05:17.302 *********** 
FAILED - RETRYING: install ceph-mgr packages on RedHat or SUSE (3 retries left).
FAILED - RETRYING: install ceph-mgr packages on RedHat or SUSE (2 retries left).
changed: [ceph-mon-02]
changed: [ceph-mon-03]
FAILED - RETRYING: install ceph-mgr packages on RedHat or SUSE (1 retries left).
fatal: [ceph-mon-01]: FAILED! => changed=false 
  attempts: 3
  changes:
    installed:
    - ceph-mgr
    - ceph-mgr-dashboard
    - ceph-mgr-diskprediction-local
  msg: |-
    Error: Package: python2-pecan-1.3.2-1.el7.noarch (centos-ceph-nautilus)
               Requires: python2-webob
  rc: 1
  results:
  - |-
    Loaded plugins: fastestmirror, priorities
    Loading mirror speeds from cached hostfile
     * base: mirror.globo.com
     * centos-ceph-nautilus: mirror.globo.com
     * epel: mirror.globo.com
     * extras: mirror.globo.com
     * updates: mirror.globo.com
    257 packages excluded due to repository priority protections

My OS is:

CentOS Linux release 7.6.1810 (Core) 

One weird thing is that it seems ceph-ansible ran different operations on ceph-mon-01, ceph-mon-02 and ceph-mon-03, and only ceph-mon-01 had errors.

I already tried to install python-2.7.16 and tried to install packages one by one, by hand, but I can't find packages with "python2-" prefix (python2-pecan, python2-webob) and the required versions.

I haven't found any error for this versions of OS and ceph/ceph-ansible using google and had no replies asking about this error on cephusers email list.

EDIT: I have the exact same problem trying to follow Ceph's installation tutorial using ceph-deploy. I get this error while trying to run:

yum install ceph-deploy ceph

1

I just stuck at "python2-pecan requires python2-webob" too.

Error: Package: python2-pecan-1.3.2-1.el7.noarch (centos-ceph-nautilus)
           Requires: python2-webob

Checked around for a while.

For example, I found webob is installed, but "Requires: python2-webob" error still happen.

In the end, I destroyed my vm and edited ceph.repo, and cp to /etc/yum.repos.d.

(as instructed by ceph doc : https://docs.ceph.com/docs/master/install/get-packages/)

And I was able to install ceph (ceph-mgr in particular) and started monitor, mgr, osd.

I guess this has something to do with package priorities.

Best Regard, JimmyYS

  • That doesn't answer the question. – RalfFriedl Aug 27 at 16:23
  • The only way I managed to install it on CentOS 7 was to install Mimic and then, once it was running correctly, update to Nautilus. – Salsa Aug 27 at 18:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.