I have on-premise AD and it syncs with Azure AD. I have setup ADDS on the Azure for AAD authentication for Azure files. I have setup the storage account and enabled the Azure Active Directory Authentication for Azure files, given appropriate permission to the user under IAM but when I try to access the File share from my on-premise computer which is joined to on-premise DC, I am unable to access the share with my AD account. I can access the share using storage name and the key.

How can I finish setting up AAD Auth?

  • when i try to access the File share from my on-premise computer which is joined to on-premise DC, i am unable to access the share with my AD account - that could literally mean anything. What exactly happens when you try to access the files? Do you get authentication errors? – joeqwerty May 30 at 0:21
  • it asks for the credential, when i enter my email address or domain credential, it does not work. it says the specified network password is not correct – Alpesh Makwana May 30 at 1:30
  • Is the on-premise computer from which you try to authenticate hybrid-joined, meaning that it (Windows 10) has a computer account on-premises and within Azure-AD as well? – desasteralex May 30 at 5:46
  • i am using windows 10, a computer account on-premises and connected to abc***.local domain – Alpesh Makwana May 30 at 6:04
  • yes, it is hybrid joined. myemail@xxxx.com and xxxx.local under Accounts>Access work or school under Windows 10 settings – Alpesh Makwana May 31 at 0:15

This won't work. The Azure Files AAD preview only supports accessing the share from machines that are joined to the Azure AD DS domain, not your on premesis domain that is synced to AAD:

Integration with AAD enables SMB access to Azure file shares using AAD credentials from AAD DS domain joined Windows VMs.


  • i created another vm in Hyper-V on my Windows 10 machine and joined to Azure AD and login with my email address and password and tried to access the share folder, i cannot. – Alpesh Makwana Jun 5 at 3:17
  • also, created a test user account in Azure AD and tried to login on the vm created in Hyper-V, it cannot find the new test account even (assign E3 license to this user) – Alpesh Makwana Jun 5 at 4:02
  • i think the vm needs to in azure vnet network, not on-premises, correct? – Alpesh Makwana Jun 5 at 4:10
  • It doesn't have to be on the vNet, unless you enable service endpoints, however what you have done also won't work. You need to join the the Azure AD DS domain using the regular domain join option in Win10, not the Join Azure AD option. – Sam Cogan Jun 5 at 13:16
  • i tried joining to abc.com not the abc.local (our domain) using regular domain join option on on-premise computer and it errored out stating ADDS service is not found. – Alpesh Makwana Jun 6 at 0:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.