0

I'm in trouble with GAE(GoogleAppEngine) deployment. I've done two turorial.

  1. https://cloud.google.com/ruby/getting-started/using-cloud-sql?hl=en
  2. https://cloud.google.com/ruby/getting-started/using-cloud-storage?hl=en

The first tutorial is success to deploy, but in the second tutorial, I cannot deploy gcloud app deploy command. In result, I found 500 error in production application.

These are error in console screen below.

Step #1: Ignoring mysql2-0.3.21 because its extensions are not built. Try: gem pristine mysql2 --version 0.3.21
Step #1: Ignoring nokogiri-1.8.2 because its extensions are not built. Try: gem pristine nokogiri --version 1.8.2
Step #1: Ignoring sqlite3-1.3.13 because its extensions are not built. Try: gem pristine sqlite3 --version 1.3.13
Step #1: Ignoring websocket-driver-0.7.0 because its extensions are not built. Try: gem pristine websocket-driver --version 0.7.0

In my local machine, I can run bundle install, start rails server and access it.

Please help me...

0

Sorry, I've resolved this problem. The reason why I cannot deploy is that I didn't execute migration. After bundle exec rake appengine:exec -- bundle exec rake db:migrate command, success to deploy!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.