6

Updated a Windows 7 machine to Windows 10 and can no longer connect to the network share on a dos machine. The MSDOS 6.22 machine is a piece of industrial hardware that uses a mapped network drive connecting via netuse x: \\smbserver\dxcontrol

The system worked prior to the update and can still connect to another win7 machine that I'm using right now while I figure this out. Both machines have identical sharing information as far as I can tell and other machines on this network (win 7 win10, macos) can see both the win 10 and win7 shares and connect without issue.

Side note is that dos doesn't support authentication so I have to share to the Everyone user and under advanced sharing settings have to select turn off password protected sharing.

The systems can all ping each other without issue.

Connecting to the windows 10 share results in the error message: Error 55: This resource does not exist on the network

Which is a different error than I see when trying to use a non existent directory on the win7 machine netuse x: \\win7dxbackup\noexist Error 67: The specified shared directory cannot be found.

And is also different than providing a non existent host (which takes a while to time out): Error 53: The computer name specified in the network path cannot be located.

Sorta running out of ideas of things to try... I'd really like to have this work with win10 vs a legacy win7 machine. I'd prefer not to use an additional network device to solve this (like a network drive or linux machine sitting in the corner collecting dust just to share this one directory)

(Edit) I'll also add that I can see both machines using net view on the dos machine.

Any help is appreciated.

5
  • 3
    You might have to install and enable SMB v1 on the Windows 10 computer. See: support.microsoft.com/en-us/help/4034314/… Also I would start the process of replacing or upgrading the industrial hardware - even if that means merely finding out how expensive it will be to do so. It might take ten years to deal with it, but those ten years should start ASAP. You don't want to have to have DOS 6.22 around any longer than necessary. – Todd Wilcox Jun 6 '19 at 17:27
  • One step forward it would seem. The system now goes right to a The password is invalid Please type password prompt. Error 5: Access has been denied. My net ver is 3.11 there is no support for user: like newer versions had. I can net logoff , net logon to a user that exists on the win10 computer but it seems it can never authenticate. I also tried blank credentials hoping it would work with guest or everyone. – dx32control Jun 6 '19 at 18:10
  • I also hear you on upgrading the systems, I've been saying it for years. The hardware upgrade costs more than the current hardware is worth and about the cost of a new machine... New machine will eventually come, but for now, I'm stuck trying to get this thing back online. – dx32control Jun 6 '19 at 18:13
  • Faced with similar situations in the past, I've just left the old OSes in place and sometimes isolated them or maintained a special workstation just for the purpose. It is messy and annoying but sometimes it's the least annoying way forward. – Todd Wilcox Jun 6 '19 at 19:08
  • That may end up being the route I take. I suspect that the windows update to disable Microsoft SMB1.0 didn't include the ability to use the passwordless sharing setting through advanced sharing options, which, in this case, also makes it incompatible with my setup. – dx32control Jun 6 '19 at 19:37
2

Todd Wilcox has the answer. You will have to re-enable SMBv1 on that Windows 10 system. You can do this by going to Control Panel\Programs and Features, and selecting "Turn Windows features on and off" on the left side. Scroll down the list until you find "SMB 1.0/CIFS Server". You can enable CIFS Client too but it shouldn't be necessary.

Like Todd mentioned, using SMBv1 (as well as a DOS system) is VERY insecure and leaves your systems vulnerable to the WannaCry ransomware vulnerability. If this is on a corporate network you would do well to follow best practices and attempt to airgap those two systems at MINIMUM. If this is on your home LAN, well, best of luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.