1

I have an IPv6-only LAN. I tried to configure eJabberd (version 16.09) with LDAP authentication an it is not working. The error is:

2019-06-11 16:17:01.256 [error] <0.407.0>@eldap:connect_bind:1096 LDAP  connection failed:
** Server: armando.unimtz.mincin.cu:389
** Reason: nxdomain
** Socket options: [{packet,asn1},{active,true},{keepalive,true},   {send_timeout,30000},binary]

I've been searching with Google and found some tips, but nothing works. I share some fragments of relevant files:

/etc/resolv.conf

domain unimtz.mincin.cu
search unimtz.mincin.cu
nameserver ::1

/etc/ejabberd/ejabberd.yml

...
auth_method:
  - ldap
ldap_servers:
  - "armando.unimtz.mincin.cu"
...

/etc/ejabberd/inetrc

{lookup,["file","native"]}.
{file, resolv, "/etc/resolv.conf"}.
{inet6, true}.

Can anyone tell me what's going on and how to solve this?

  • Have you tried manually entering in the IPv6 address as [2001:db8]:389? does dig armando.unimtz.mincin.cu AAAA give any results? does this IP match your ldap server? – Jacob Evans Jun 11 at 20:45
  • I have fully control over the internal domain and I can resolve perfectly everything. I can resolve with 'dig' and 'nslookup' and do 'ping' to that name. – Leinier Jun 11 at 23:37
  • 1
    see bug, are you running 18.06 or newer? blog.process-one.net/ejabberd-18-06 bugs.debian.org/cgi-bin/bugreport.cgi?bug=895692 – Jacob Evans Jun 12 at 17:43
  • I'm using 16.09 which is in the stable branch of Debian GNU/Linux repo. Thanks. I read that I must to upgrade to +18.06. I don't see how to give you +1. Thanks. – Leinier Jun 14 at 16:29
  • @Leinier Buster, the next Debian stable release, is to be released in a couple of days, July 6th 2019. Maybe that's an option for you. Good luck! – gf_ Jun 14 at 21:53
1

LDAP tries to bind / connect to armando.unimtz.mincin.cu which is not possible, as the error indicates: NXDOMAIN, which means that the domain doesn't exist. Probably, it's worth checking your DNS and/or the hosts file(s) in use.

  • I know what that error mean and I know everybody will take the path of the DNS server, but, the DNS is fully working. I think eJabberd is trying to resolve the A record of that DNS name, but, obviously that doesn't exist because my network is IPv6-only. I tried to use the IPv6 address and didn't work. – Leinier Jun 11 at 23:38
  • Well, do a tcpdump or something on the client. See what DNS requests it sends. – Zoredache Jun 12 at 0:19
  • I think I will solve nothing with that but to know what kind of DNS request eJabberd is doing. Seem that anybody is not using eJabberd in an IPv6-only scenario. If somebody knows how to solve this, post the solution, please.Thanks anyway. – Leinier Jun 12 at 2:48
0

This is a bug (bug report) and is fixed in a newer version. Please upgrade to version 18.06 (release notes) or newer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.