1

I'm trying to get erlang installed so I can installed rabbitMQ. Here's my sequence and error:

>yum install erlang
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
              : manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Resolving Dependencies
--> Running transaction check
---> Package erlang.x86_64 0:22.0.4-1.el7 will be installed
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: erlang-22.0.4-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: erlang-22.0.4-1.el7.x86_64 (rabbitmq_erlang)
           Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

My linux info is:

>cat /proc/version
Linux version 3.10.0-327.el7.x86_64 (mockbuild@x86-034.build.eng.bos.redhat.com) (gcc version 4.8.3 20140911 (Red Hat 4.8.3-9) (GCC) ) #1 SMP Thu Oct 29 17:29:29 EDT 2015

>cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.2 (Maipo)

>cat /etc/*elease
NAME="Red Hat Enterprise Linux Server"
VERSION="7.2 (Maipo)"
ID="rhel"
ID_LIKE="fedora"
VERSION_ID="7.2"
PRETTY_NAME="Red Hat Enterprise Linux Server 7.2 (Maipo)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7.2:GA:server"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"

REDHAT_BUGZILLA_PRODUCT="Red Hat Enterprise Linux 7"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.2
REDHAT_SUPPORT_PRODUCT="Red Hat Enterprise Linux"
REDHAT_SUPPORT_PRODUCT_VERSION="7.2"
Red Hat Enterprise Linux Server release 7.2 (Maipo)
Red Hat Enterprise Linux Server release 7.2 (Maipo)

...and here's my openssl info:

>openssl version
OpenSSL 1.0.2s  28 May 2019

Where can I find and install libcrypto.so.10(OPENSSL_1.0.2)(64bit)?

Thanks for your help!

  • Any good reason not to upgrade to latest 7.x? – Patrick Mevzek Jun 18 at 19:28
  • Hi, @PatrickMevzek. Thanks for your help. Sorry to be dense. I'm not sure what I'm doing. 7.x of what? And where? – Jonathan M Jun 18 at 19:29
1

Your RHEL server does not have an active subscription, but this is required to install packages. You need to register the system using subscription-manager register and an existing or new entitlement. If you haven't got a Red Hat Enterprise Linux subscription, you will need to purchase one.

Once your system is properly subscribed, the warning message will no longer appear when you run yum and you will be able to install packages.

  • 1
    Thanks, Michael. This is just a dev virtual server spun up to test rabbitMQ. Is there any way to acquire the needed dependencies without going through a subscription process? – Jonathan M Jun 18 at 19:45
  • Try using CentOS instead of RHEL in this case. Or ask whoever in your IT department manages your company's RHEL subscriptions if they have an option they can give you. For instance, they could issue activation keys for such virtual machines and then unregister them after a few weeks or when they're no longer needed. – Michael Hampton Jun 18 at 19:48
  • The end of the answer in your first link says Centos avoids the problem. I thought I was using Centos currently. Am I not? How can I tell? Sorry again for being so dense. – Jonathan M Jun 18 at 19:48
  • You showed this information right in your question! cat /etc/redhat-release – Michael Hampton Jun 18 at 19:49
  • 1
    @JonathanM In that question, the accepted answer is unfortunately wrong. Your options are to subscribe your system or use CentOS instead. – Michael Hampton Jun 18 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.