When trying to install the .NET Framework version 4.7.2, it gets stuck on the installation and freezes here:

enter image description here

I waited for over an hour for the .NET Framework to install, and it stayed at the same spot. I attempted to cancel the installation, and it's stuck on rolling back the installation as well:

enter image description here

Is there anything I need to change on the OS to be able to install the .NET Framework? I'm not sure why it's stuck on this spot, and any advice would be appreciated.

  • Does the issue appear with the offline bundle too, and what the setup log show ?
    – yagmoth555
    Jun 19, 2019 at 20:27
  • I haven't tried the offline bundle. I cancelled the installation and unfortunately it doesn't show as installed in Programs and Features, but I can't attempt a reinstallation because it says it is already installed. I'm not sure why this is, so I'll do some digging to try and fix it. Jun 19, 2019 at 20:42
  • 1
    I reinstalled Windows 10, then attempted to install .NET Framework 4.7.2 with the offline installer. It worked perfectly. I'm not sure why the online installer errored out, but if you want to post the answer to the issue as using the offline installer, I'll accept it. Jun 20, 2019 at 20:23

2 Answers 2


I would give a try with the offline bundle. It often resolve strange issue that the online's bundle can have.

If the first step don't work, you can see the MSI error log too, which can give some hints.

  • 1
    the same problem with 4.8 :( I'm trying offline installer but I had to restart the server to make installation progress to move
    – oleksa
    Dec 19, 2019 at 12:16

In my experience and across many .Net releases, very often the issue is that the .Net installer setup wants to launch the Windows Installer service, and if for any reason that fails to start it will sit there forever waiting. Manually starting the installer service via Admin Tools / Services will kick the progress back into life.

  • This resolved the issue for me! Oct 9, 2020 at 22:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .