0

I'm using ejabberd for communications. While sending files using xmpp client (f.e. gajim) occurs certificate error:

Upload_file   

CERTIFICATE_VERIFY_FAILED

Certificate exists, tried to uncomment no_sslv3 in conf - same result. What can cause it? In addition any info, about how file transfering works (can NAT effect on ssl) and is it possible to check if cert is correct would be great.

  • Certificates contain a number of properties that need to be valid (hostname and dates among the most notable) and depend on a chain of trust. Verification will fail when either those properties are incorrect, or when the certificate is not signed by a trusted root certificate (for instance a self signed certificate) or signed with a missing intermediate/chain certificate. – HBruijn Jun 20 at 7:55
  • Well, I have self-signed certificate in this case. Maybe you know, how certificate verification in file transfer works? Like server's ssl? – Jane Jun 20 at 8:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.