1

We have a new customer running SBS 2003 SP2 (standalone) whose AD not working. At first glance it looks like the cause is the fact that the AD integrated forward lookup zone is missing, so directory services won't start. Because Directory Services won't start I am unable to readd or restore the AD integrated zone.

Any suggestions on a fix?

Edit:

Would this re add the zone?

Ntsdutil

Authoritative restore

Restore subtree “dc=DeletedZone.com,cn=MicrosoftDNS,dc=forestDNSZones,dc=contoso,dc=com”

3
  • Looking forward to an answer to this.
    – Dave M
    Dec 24 '09 at 17:29
  • Look through the event log and tell us any pertinent errors that are there. Event IDs can be a big help.
    – Wesley
    Dec 24 '09 at 17:55
  • Event 4015 is the main one I see and seems to have started them all
    – ITGuy24
    Dec 24 '09 at 19:31
1
+150

Have you tried this solution?

  1. Start Add or Remove Programs->Add/Remove Windows Components.

  2. Double click on Networking Services and then uncheck DNS.

  3. Click Next to finish the un-installation.

  4. Find and remove the following files:

%systemroot%\Windows\System32\DNS\Cache.dns

%systemroot%\Windows\System32\Config\Netlogon.dns

%systemroot%\Windows\System32\Config\Netlogon.dnb

  1. Reinstall DNS.

  2. Restart the server and test this issue.

There is also this article from MS that sound as if it applies:

MS Tech Article

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.