0

I have set up a VM with Microsoft SQL Server 2017 installed on the Google Cloud Platform. I am able to access the server on the VM by using SQL Management Studio.

The purpose of this server is for training a group of people over the next month. As such I want to set up a SQL user for each person in the group to allow them to log into the server remotely by using only an IP address.

I have set up rules in the Google Cloud firewall as well as in the Windows Server 2016 firewall. In both cases I allow TCP / UDP connections. Unfortunately I can still not connect to the server by using the same IP address I use to connect through RDP. Have I missed any steps?

Thanks in advance for any help!

1
  • What is your question? In your first paragraph, you say that you can connect using SQL Management Studio. In your third paragraph, you cannot connect. Cannot connect using what? You say that you have defined firewall rules. Include those rules in your question. Show the command that you are using and the exact error message(s). Commented Jun 24, 2019 at 0:53

1 Answer 1

1

After deploying the SQL server you must reserve a Static External IP Address [1] and then assign the address to the VM instance with the SQL [2].

Then you can open the server ports following this public documentation [3].

This will be enough to make it work. If you are experimenting issues it would be nice to have more details like what is the error message, some screenshots about your firewalls rules inside the OS and on GCP.

Hope it works for you.


[1] https://cloud.google.com/compute/docs/ip-addresses/reserve-static-external-ip-address#reserve_new_static

[2] https://cloud.google.com/compute/docs/ip-addresses/reserve-static-external-ip-address#assign_new_instance

[3] https://docs.bitnami.com/google/faq/administration/use-firewall/

1
  • Thanks for the help Alan. I have managed to get it working by allowing all IP addresses and creating SQL Server Authentication users. This is probably not the safest option but it works well for teaching purposes.
    – TJVR
    Commented Jun 27, 2019 at 9:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .