0

while starting deepstream output show like this how can i resolve this issue. I installed the latest version which is not available in yum repo by using rpm file and i can't remove this package too..shows the same error. please help

deepstream: /lib64/libstdc++.so.6: version GLIBCXX_3.4.20' not found (required by deepstream) deepstream: /lib64/libstdc++.so.6: versionGLIBCXX_3.4.21' not found (required by deepstream) deepstream: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by deepstream)

0

This was most likely built on a different OS version, one that had a newer version of gcc/g++/libstdc++

You can either chase down a newer version of libstdc++ and put it somewhere that your app can find it (using LD_LIBRARY_PATH) or build from source.

Personally I’d not chase this stuff down and I’d run it under docker. There seems to be an official image at https://hub.docker.com/r/deepstreamio/deepstream.io/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.