1

I have a server running CentOS release 6.10 (Final). I would like to upgrade this to latest CentOS 7.x release. To do this, when I am trying to install upgrade tools to help start with upgrade:

sudo yum install redhat-upgrade-tool preupgrade-assistant-contents

It is giving many errors e.g.

Error: Package: python34-3.4.10-1.el7.x86_64 (epel) Requires: libpthread.so.0()(64bit) Error: Package: php-common-5.6.40-9.el7.remi.x86_64 (remi-php56) Requires: libpthread.so.0(GLIBC_2.2.5)(64bit) Error: Package: php-cli-5.6.40-9.el7.remi.x86_64 (remi-php56) Requires: libstdc++.so.6()(64bit) Error: Package: php-cli-5.6.40-9.el7.remi.x86_64 (remi-php56) Requires: ld-linux-x86-64.so.2()(64bit) Error: Package: python34-libs-3.4.10-1.el7.x86_64 (epel) Requires: libreadline.so.6()(64bit) Error: Package: libdb4-utils-4.8.30-13.el7.x86_64 (epel) Requires: libpthread.so.0(GLIBC_2.2.5)(64bit).....

The list is quite large and I am not sure why is it giving this error because I continued to keep this server updated with latest updates from its own repo and still I am getting these errors.

Can anyone look into this and let me know if I am missing something here?

Thanks.

  • Is your current EL6 system 32bit? – Sven Jun 25 at 10:50
  • It is 64-bit (x86_64). – Meraj Rasool Jun 25 at 10:55
-1

There is not an officially supported direct upgrade path from CentOS 6.x to 7.x so the process is to backup the CentOS 6.x server, followed by a new install of CentOS 7.x and then import the back up data from you old CentOS 6.x server.

  • while I believe their are tools that allow an in place upgrade when I was doing this last year - it turned out to be quicker and safer to follow the install new and migrate the data across approach. – fcbsd Jun 25 at 11:03
  • 1
    Yes. Going with a fresh install is a better option as trying to upgrade existing installation is creating so many dependencies that I won't like. – Meraj Rasool Jun 25 at 11:43
1

Red Hat does provide support of a major version upgrade from RHEL 6 to 7, but only in some specific scenario's with some rather strict requirements. The same also holds also for CentOS 6 --> 7 upgrades

See the Migration PLanning Guide for the current requirements and details, but one requirement is that:

Your system includes only the following package groups:

  • Minimal
  • Base
  • Web Server
  • DHCP Server
  • NFS File Server (@nfs-server)
  • Print Server
  • CIFS file server

Remove other package groups before upgrading and reinstall them when your upgrade is complete.

The debug output you show that you (still) have packages installed from unsupported packages groups and repositories that are not in-scope for the upgrade tool :
python34-3.4.10-1.el7.x86_64 (epel)
php-common-5.6.40-9.el7.remi.x86_64 (remi-php56)

In general: do a fresh install rather than a major version upgrade.
Also with the recent release of RHEL 8 I wait a bit for the release of CentOS 8 : https://wiki.centos.org/About/Building_8

  • 1
    For now will go with fresh install. I hope upgrading from 7 to 8 would be much simpler. – Meraj Rasool Jun 25 at 11:51
  • With the long term support cycles Red Hat offers the differences between major versions are always significant. Depending on the packages you have installed and any customization in their configuration that you made, reliable automated upgrades are (potentially) difficult. Therefor a migration might be more reliable and will allow you to take advantage of new features, methods and best practices. – HBruijn Jun 25 at 12:00
  • I did quite a few 6-7 upgrades a few years back; they all went OK but I didn't have obsolete software installed. 7-8 is even easier, but 8 isn't really ready for many workloads as EPEL 8 doesn't exist yet, and virtually everybody has something that requires EPEL. – Michael Hampton Jun 25 at 17:22
0

You have an obsolete PHP version installed, which is blocking your CentOS upgrade.

To resolve the problem, upgrade to a Remi repository containing a current PHP version. Then try the CentOS 6-7 upgrade again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.