0

Simple task: I've assigned a V6 address to a debian9 box, but its not applying to the interface on reboot. The V4 address is applying. If i assign it manually using ip -6 addr add <ipv6address>/<prefixlength> dev <interface> then it works fine. Here's a copy of my /etc/network/interfaces config

'# The loopback network interface
auto lo
iface lo inet loopback
iface lo inet6 loopback

'# The primary network interface
allow-hotplug eth0
iface eth0 inet static
address 10.190.xxx.xxx/26
gateway 10.190.xxx.xxx
up route add -net 10.100.xx.xxx/32 gw 10.190.xxx.xxx dev eth0
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 8.8.8.8 4.2.2.2

iface eth0 inet6 static
address 2607:f0x0:xxxx:ac::20
netmask 64
gateway 2607:f0x0:xxxx:ac::2

5
  • Try doing an ifup --force eth0 from an shell with root privs. Tell us the error.
    – Zoredache
    Jun 27, 2019 at 16:46
  • I get the following error: RTNETLINK answers: File exists ifup: failed to bring up eth0
    – Joe
    Jun 27, 2019 at 16:47
  • Might need to do an ifdown --force eth0. Might also need to try commenting out your ipv4 section temporarily, and trying to down+up the interface. The settings are applied in order and any failure will immediately abort.
    – Zoredache
    Jun 27, 2019 at 16:54
  • This is odd. The ifup/ifdown operation works, because the interface goes down and up (as in the box becomes unreachable/reachable), but each operation throws an error. the ifup operation is the above error, ifdown returns: RTNETLINK answers: No such process RTNETLINK answers: Cannot assign requested address
    – Joe
    Jun 27, 2019 at 17:06
  • What tells if config, @joe this is normal i aint seen that without doing that for years
    – djdomi
    Jun 27, 2019 at 20:42

2 Answers 2

0

If you use ifupdown2 package, try to install ifupdown instead. This fixed the issue for me.

0

You just need one stanza for an interface with ifupdown2:

# The primary network interface
auto eth0
iface eth0
    address 10.190.xxx.xxx/26
    gateway 10.190.xxx.xxx
    address 2607:f0x0:xxxx:ac::20/64
    gateway 2607:f0x0:xxxx:ac::2 
    dns-nameservers 9.9.9.9 149.112.112.112
    post-up ip route add 10.100.xx.xxx/32 via 10.190.xxx.xxx dev eth0

The config file "/etc/network/interfaces" is not quite the same for ifupdown and ifupdown2. There is a comparison at cumulus network of some differences.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .