0

I have 3 servers svrA, svrB, and svrC. svrA and svrB need to call a web service (http://example.com/api/consoleServices) hosted in svrC.

Now the issue is sometimes I am able to get the response from svrC in svrA and no response in svrB and then again sometimes I am able to get the response from svrC in svrB and no response in svrA.

here is the curl response: svrA:

[root@svrA ~]#  curl -v -X POST -H "Content-Type: application/json"  -d '{"method":"login","user_id":"supAdmin","password":"xxxxxxxxxxxxxxxxxxxxxxxxxx":0,"intUserType":1,"intPortalType":"GV","ipAddress":"::1","userAgent":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko\/20100101 Firefox\/60.0"}'  http://example.com/api/consoleServices
* About to connect() to example.com port 80 (#0)
*   Trying 192.168.24.9...
* Connected to example.com (192.168.24.9) port 80 (#0)
> POST /api/consoleServices HTTP/1.1
> User-Agent: curl/7.29.0
> Host: example.com
> Accept: */*
> Content-Type: application/json
> Content-Length: 245
>
* upload completely sent off: 245 out of 245 bytes
< HTTP/1.1 200 OK
< Date: Tue, 02 Jul 2019 06:41:26 GMT
< Server: Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips PHP/7.1.30
< X-Powered-By: PHP/7.1.30
< Access-Control-Allow-Origin: *
< Cache-Control: no-cache, private
< X-RateLimit-Limit: 5000
< X-RateLimit-Remaining: 4998
< Connection: keep-alive
< Access-Control-Allow-Origin: *
< Content-Length: 0
< Content-Type: text/html; charset=UTF-8
<
* Connection #0 to host example.com left intact

svrB:

[root@svrB conf]# curl -v -X POST -H "Content-Type: application/json"  -d '{"method":"login","user_id":"admin","password":"xxxxxxxxxxxxxxxxxxxxxxxxxx>998ecf8427e":0,"intUserType":1,"intPortalType":"GV","ipAddress":"::1","userAgent>":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko\/20100101 Firefox\/60.0"}'  http://example.com/api/consoleServices
* About to connect() to example.com port 80 (#0)
*   Trying 192.168.24.9...
* Connected to example.com (192.168.24.9) port 80 (#0)
> POST /api/consoleServices HTTP/1.1
> User-Agent: curl/7.29.0
> Host: example.com
> Accept: */*
> Content-Type: application/json
> Content-Length: 245
>
* upload completely sent off: 245 out of 245 bytes

What could be the error

  • What does the web server error log say? What about the web service application log? – Andrew Schulman Jul 12 at 11:52
  • there is no entry in the webserver log of server C. But i am able to see connection coming to server C via tcpdump – swogat Jul 12 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.