1

I used these commands:

yum remove php*
yum install php71u php71u-cli php71u-common php71u-gd php71u-mbstring php71u-mysqlnd php71u-pdo php71u-xml php71u-json

and I installed php 7.1

After that i tried to install php package with that command:

yum install php-bcmath

But server returned response that:

---> Package php-common.x86_64 0:5.4.16-46.el7 will be installed
--> Processing Conflict: php71u-common-7.1.29-1.el7.ius.x86_64 conflicts php-common < 7.1.29-1.el7.ius
--> Processing Conflict: php71u-json-7.1.29-1.el7.ius.x86_64 conflicts php-json < 7.1.29-1.el7.ius

After that i used that command:

yum install php71-php-bcmath.x86_64

And installed successfuly. When I used "php -m" command the module was not seen?

What could be problem? And how can I solve this?

1

The PHP core packages installed are the from the IUS repo (php71u) so that means you should install php71u-bcmath to have that module wire up with the IUS PHP installation.

php-bcmath is the default CentOS PHP module so it will conflict. php71-php-bcmath may be from the SCLo repo which doesn't explicitly conflict with the IUS PHP, but is not the one you installed so it will not automatically enable itself with php71u.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.