0

I'm running Ubuntu 16.04 with Apache + PHP7.1-FPM, and have a script that consistently times out after 60 sec with a 504 Gateway Time-Out error. For the life of me, I can't find what config setting is limiting the script. I've made the following changes to my settings:

/etc/php/7.1/fpm/php.ini

  • max_execution_time = 600
  • max_input_time = 300
  • memory_limit = 512M
  • default_socket_timeout = 600

/etc/php/7.1/fpm/pool.d/www.conf

  • request_terminate_timeout = 0

/etc/apache2/apache2.conf

  • Timeout = 600

I've confirmed the PHP settings are working (via phpinfo()). What other config settings do I need to be looking for? I don't get anything of value in the apache2 or php-fpm error logs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.