0

i am trying to recover mysql database , but no success.

the error message i get in the user.err file

190709 12:28:14 [Note] Plugin 'FEDERATED' is disabled.
190709 12:28:14 InnoDB: The InnoDB memory heap is disabled
190709 12:28:14 InnoDB: Mutexes and rw_locks use Windows interlocked functions
190709 12:28:14 InnoDB: Compressed tables use zlib 1.2.3
190709 12:28:14 InnoDB: Initializing buffer pool, size = 128.0M
190709 12:28:14 InnoDB: Completed initialization of buffer pool
InnoDB: Error: auto-extending data file .\ibdata1 is of a different size
InnoDB: 64 pages (rounded down to MB) than specified in the .cnf file:
InnoDB: initial 640 pages, max 0 (relevant if non-zero) pages!
190709 12:28:14 InnoDB: Could not open or create data files.
190709 12:28:14 InnoDB: If you tried to add new data files, and it failed here,
190709 12:28:14 InnoDB: you should now edit innodb_data_file_path in my.cnf back
190709 12:28:14 InnoDB: to what it was, and remove the new ibdata files InnoDB created
190709 12:28:14 InnoDB: in this failed attempt. InnoDB only wrote those files full of
190709 12:28:14 InnoDB: zeros, but did not yet use them in any way. But be careful: do not
190709 12:28:14 InnoDB: remove old data files which contain your precious data!
190709 12:28:14 [ERROR] Plugin 'InnoDB' init function returned error.
190709 12:28:14 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
190709 12:28:14 [ERROR] Unknown/unsupported storage engine: INNODB
190709 12:28:14 [ERROR] Aborting

what i tried

  1. installed mysql in another computer with same path as crashed database
  2. created an empty database with same name as old.
  3. stopped mysql service in new computer
  4. backup files in new computer mysql/data
  5. copied old files ib_logfile0,ib_logfile1, and ibdata1 to new computer mysql/data directory
  6. start mysql in new computer

i get the error message

crash error message

  • It sounds like my.cnf was modified, or a different config file is being used. – Rick James Jul 9 at 21:31
  • i dont have my.cnf instead my.ini is this the same file, if yes, there is no innodb_data_file_path in the file but i have datadir and datadir – Smith Jul 10 at 6:29
1

Check what's the current size of ibdata1 file or even better check my.cnf on old machine and set parameter innodb_data_file_path in my.cnf on new box to match ibdata1 size / old config

  • i don't have any my.cnf i the installation dir of both, instead my.ini is this the same file there is no innodb_data_file_path in the file but i have datadir and datadir – Smith Jul 10 at 6:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.