0

I can not install or remove any package using apt. Gnome desktop environment does not work either.

root@debian:~# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 10 (buster)
Release:        10
Codename:       buster

...

root@debian:~# uname -a
Linux debian 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1 (2019-04-12) x86_64 GNU/Linux

...

root@debian:~# apt update
Hit:1 http://cdn-fastly.deb.debian.org/debian buster InRelease
Hit:2 http://cdn-fastly.deb.debian.org/debian-security buster/updates InRelease
Hit:3 http://cdn-fastly.deb.debian.org/debian buster-updates InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
369 packages can be upgraded. Run 'apt list --upgradable' to see them.

...

root@debian:~# apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 va-driver-all : Depends: mesa-va-drivers but it is not installed
 va-driver-all:i386 : Depends: mesa-va-drivers:i386 but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

...

root@debian:~# apt install mesa-va-drivers
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 va-driver-all:i386 : Depends: mesa-va-drivers:i386 but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

...

root@debian:~# apt install mesa-va-drivers:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 va-driver-all : Depends: mesa-va-drivers but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

...

root@debian:~# apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  alsa-base bridge-utils cpufrequtils dmz-cursor-theme docbook-xml ebtables freerdp-x11 gcj-6-jre-lib gir1.2-mate-panel gir1.2-matepanelapplet-4.0
  gnome-accessibility-themes gnome-themes-standard gnupg-agent guile-2.0-libs libapparmor-perl libattr1:i386 libbabeltrace-ctf1 libbind9-140 libblas-common
  libboost-chrono1.62.0 libboost-python1.62.0 libboost-random1.62.0 libboost-regex1.67.0 libboost-thread1.62.0 libclang1-3.9 libcomerr2:i386
  libdns-export162 libdns162 libegl-mesa0:i386 libegl1:i386 libetpan17 libfile-copy-recursive-perl libfreerdp-cache1.1 libfreerdp-client1.1
  libfreerdp-codec1.1 libfreerdp-common1.1.0 libfreerdp-core1.1 libfreerdp-crypto1.1 libfreerdp-gdi1.1 libfreerdp-locale1.1 libfreerdp-plugins-standard
  libfreerdp-primitives1.1 libfreerdp-rail1.1 libfreerdp-utils1.1 libgbm1:i386 libgcab-1.0-0 libgcj-common libgcj17 libgcr-3-common libgfortran3
  libgmime-2.6-0 libgnome-autoar-common libgnome-games-support-1-2 libgom-1.0-common libgutenprint2 libhttp-parser2.1 libicu57:i386 libidn11:i386
  libisc-export160 libisc160 libisccc140 libisccfg140 libjim0.76 libllvm4.0 liblouis12 liblouisutdml7 liblvm2app2.2 liblvm2cmd2.02 liblwres141
  libmono-data-tds4.0-cil libnotmuch4 libntfs-3g871 libonig4 libpisock9 libprocps6 librados2 librarian0 librbd1 libsmpeg0 libsndio6.1:i386 libsodium18
  libstd-rust-1.24 libstdc++-4.9-dev libsuitesparseconfig4 libtinfo-dev libtomcrypt0 libtommath1 libunbound2 libwayland-egl1-mesa:i386
  libwayland-server0:i386 libwinpr-crt0.1 libwinpr-crypto0.1 libwinpr-dsparse0.1 libwinpr-environment0.1 libwinpr-error0.1 libwinpr-file0.1
  libwinpr-handle0.1 libwinpr-heap0.1 libwinpr-input0.1 libwinpr-interlocked0.1 libwinpr-library0.1 libwinpr-path0.1 libwinpr-pool0.1 libwinpr-registry0.1
  libwinpr-rpc0.1 libwinpr-sspi0.1 libwinpr-synch0.1 libwinpr-sysinfo0.1 libwinpr-thread0.1 libwinpr-utils0.1 libxen-4.8 libxfont1 libxfreerdp-client1.1
  linux-headers-4.9.0-8-amd64 linux-headers-4.9.0-8-common linux-image-4.9.0-8-amd64 openbios-ppc openbios-sparc openhackware python-certifi python-imaging
  python-pam python-requests python-twisted-web python-urllib3 python-zeitgeist python3-pyasn1 qemu-slof qemu-system qemu-system-mips qemu-system-misc
  qemu-system-ppc qemu-system-sparc qemu-user qemu-user-binfmt rarian-compat sgml-data snap-confine tcpd ubuntu-core-launcher xml-core
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
  mesa-va-drivers mesa-va-drivers:i386
The following NEW packages will be installed:
  mesa-va-drivers mesa-va-drivers:i386
0 upgraded, 2 newly installed, 0 to remove and 369 not upgraded.
2 not fully installed or removed.
Need to get 0 B/4,105 kB of archives.
After this operation, 38.9 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 415628 files and directories currently installed.)
Preparing to unpack .../mesa-va-drivers_18.3.6-2_i386.deb ...
Unpacking mesa-va-drivers:i386 (18.3.6-2) ...
dpkg: error processing archive /var/cache/apt/archives/mesa-va-drivers_18.3.6-2_i386.deb (--unpack):
 trying to overwrite '/usr/lib/i386-linux-gnu/dri/nouveau_drv_video.so', which is also in package vdpau-va-driver:i386 0.7.4-dmo5
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Preparing to unpack .../mesa-va-drivers_18.3.6-2_amd64.deb ...
Unpacking mesa-va-drivers:amd64 (18.3.6-2) ...
dpkg: error processing archive /var/cache/apt/archives/mesa-va-drivers_18.3.6-2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/dri/nouveau_drv_video.so', which is also in package vdpau-va-driver:amd64 0.7.4-dmo5
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/mesa-va-drivers_18.3.6-2_i386.deb
 /var/cache/apt/archives/mesa-va-drivers_18.3.6-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

...

root@debian:~# apt full-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 va-driver-all : Depends: mesa-va-drivers but it is not installed
 va-driver-all:i386 : Depends: mesa-va-drivers:i386 but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

...

apt-get remove ".*:i386"
...
...
...
Package 'zangband:i386' is not installed, so not removed
Package 'bro:i386' is not installed, so not removed
Package 'dosbox:i386' is not installed, so not removed
Package 'dosbox-debug:i386' is not installed, so not removed
Package 'libzmq3-dev:i386' is not installed, so not removed
Package 'libzmq5:i386' is not installed, so not removed. Did you mean 'libzmq5'?
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 va-driver-all : Depends: mesa-va-drivers but it is not going to be installed
 wine-stable : Depends: wine-stable-i386 (= 4.0.1~stretch)
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

...

root@debian:~# apt purge va-driver-all
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 va-driver-all:i386 : Depends: mesa-va-drivers:i386 but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

...

root@debian:~# apt purge va-driver-all:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 va-driver-all : Depends: mesa-va-drivers but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
  • Do you actually need that package? Try uninstalling it. Do you actually need the i386 support? Try removing that? – Zoredache Jul 10 at 22:08
  • I do not need that specific package, but I think it is related to a graphic driver and I need a graphic desktop environment. – Fernando Valdés Jul 10 at 22:19
  • I have tried to uninstall using apt and get the same error. – Fernando Valdés Jul 10 at 22:19
  • List all the packages at the same time in your remove apt-get remove mesa-va-drivers va-driver-all va-driver-all:i386. In any cause, if that doesn't work, just restore your backup before you upgraded, or re-install. – Zoredache Jul 10 at 22:39
  • After running the full command (apt-get remove mesa-va-drivers va-driver-all va-driver-all: i386) it worked. Packages va-driver-all: amd64 and va-driver-all: i386 were removed. Thanks. – Fernando Valdés Jul 10 at 22:57
0

Thanks to @Zoredache, the following works for me:

root@debian:~# apt-get remove mesa-va-drivers va-driver-all va-driver-all:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package 'mesa-va-drivers' is not installed, so not removed
The following packages were automatically installed and are no longer required:
  alsa-base bridge-utils cpufrequtils dmz-cursor-theme docbook-xml ebtables freerdp-x11 gcj-6-jre-lib gir1.2-mate-panel gir1.2-matepanelapplet-4.0
  gnome-accessibility-themes gnome-themes-standard gnupg-agent guile-2.0-libs libapparmor-perl libattr1:i386 libbabeltrace-ctf1 libbind9-140 libblas-common
  libboost-chrono1.62.0 libboost-python1.62.0 libboost-random1.62.0 libboost-regex1.67.0 libboost-thread1.62.0 libclang1-3.9 libcomerr2:i386
  libdns-export162 libdns162 libegl-mesa0:i386 libegl1:i386 libetpan17 libfile-copy-recursive-perl libfreerdp-cache1.1 libfreerdp-client1.1
  libfreerdp-codec1.1 libfreerdp-common1.1.0 libfreerdp-core1.1 libfreerdp-crypto1.1 libfreerdp-gdi1.1 libfreerdp-locale1.1 libfreerdp-plugins-standard
  libfreerdp-primitives1.1 libfreerdp-rail1.1 libfreerdp-utils1.1 libgbm1:i386 libgcab-1.0-0 libgcj-common libgcj17 libgcr-3-common libgfortran3
  libgmime-2.6-0 libgnome-autoar-common libgnome-games-support-1-2 libgom-1.0-common libgutenprint2 libhttp-parser2.1 libicu57:i386 libidn11:i386
  libisc-export160 libisc160 libisccc140 libisccfg140 libjim0.76 libllvm4.0 liblouis12 liblouisutdml7 liblvm2app2.2 liblvm2cmd2.02 liblwres141
  libmono-data-tds4.0-cil libnotmuch4 libntfs-3g871 libonig4 libpisock9 libprocps6 librados2 librarian0 librbd1 libsmpeg0 libsndio6.1:i386 libsodium18
  libstd-rust-1.24 libstdc++-4.9-dev libsuitesparseconfig4 libtinfo-dev libtomcrypt0 libtommath1 libunbound2 libwayland-egl1-mesa:i386
  libwayland-server0:i386 libwinpr-crt0.1 libwinpr-crypto0.1 libwinpr-dsparse0.1 libwinpr-environment0.1 libwinpr-error0.1 libwinpr-file0.1
  libwinpr-handle0.1 libwinpr-heap0.1 libwinpr-input0.1 libwinpr-interlocked0.1 libwinpr-library0.1 libwinpr-path0.1 libwinpr-pool0.1 libwinpr-registry0.1
  libwinpr-rpc0.1 libwinpr-sspi0.1 libwinpr-synch0.1 libwinpr-sysinfo0.1 libwinpr-thread0.1 libwinpr-utils0.1 libxen-4.8 libxfont1 libxfreerdp-client1.1
  linux-headers-4.9.0-8-amd64 linux-headers-4.9.0-8-common linux-image-4.9.0-8-amd64 openbios-ppc openbios-sparc openhackware python-certifi python-imaging
  python-pam python-requests python-twisted-web python-urllib3 python-zeitgeist python3-pyasn1 qemu-slof qemu-system qemu-system-mips qemu-system-misc
  qemu-system-ppc qemu-system-sparc qemu-user qemu-user-binfmt rarian-compat sgml-data snap-confine tcpd ubuntu-core-launcher xml-core
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  va-driver-all va-driver-all:i386
0 upgraded, 0 newly installed, 2 to remove and 369 not upgraded.
2 not fully installed or removed.
After this operation, 45.1 kB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 415627 files and directories currently installed.)
Removing va-driver-all:amd64 (2.4.0-1) ...
Removing va-driver-all:i386 (2.4.0-1) ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.