0

I have tried almost anything - my internet connection 500 Mbit/s I connect from the same external IP subnet so my speed to the server is also 500 Mbit/s.

When i use wget from my l2tp server i have 450 Mbit/s download. When i connect to this server from windows host via l2tp/ipsec and do speed test of the internet connection i get around 1.5 Mbit/s

my Strongswan ipsec.conf:

config setup

conn %defult
    ikelifetime=28800s
    lifetime=3600s
    keyingtries=1
    keyexchange=ikev1

conn L2TP
    ike=aes256-sha256-modp1024
    esp=aes256-sha256
    authby=secret
    left=212.14.7.22
    leftid=212.14.7.22
    leftprotoport=17/%any
    rightprotoport=17/%any
    right=%any
    rightsubnet=0.0.0.0/0
    ikelifetime=8h
    keylife=1h
    rekey=no
    auto=add
    type=transport
    fragmentation=yes
    dpddelay=30
    dpdtimeout=120
    dpdaction=clear

conn clear
    auto=ignore

My xl2tpd.conf:

[global]
  port = 1701

[lns default]
  ip range = 10.111.111.2-10.111.111.102
  local ip = 10.111.111.1
  require chap = yes
  refuse pap = yes
  require authentication = yes
  name = hub-d10-l2tpd
  ppp debug = yes
  pppoptfile = /etc/ppp/options.xl2tpd
  length bit = yes

my options.xl2tpd:

ipcp-accept-local
ipcp-accept-remote
require-mschap-v2
ms-dns 8.8.8.8
proxyarp
noccp
auth
debug
defaultroute
idle 1800
mtu 1280
mru 1280
connect-delay 5000

Iptables as easy as it can be:

# Generated by xtables-save v1.8.2 on Thu Jul 11 09:00:00 2019
*nat
:PREROUTING ACCEPT [0:0]
:INPUT ACCEPT [0:0]
:POSTROUTING ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
-A POSTROUTING -s 10.111.111.0/24 -o ens192 -j MASQUERADE
COMMIT
# Completed on Thu Jul 11 09:00:00 2019

I have tried to change mtu/mru from 1200 to 1420 - didn't helped. This is fresh Debian 10 install but i have also tried on Deb 9. Any ideas ?

0

OK, finally have found a problem. It was my laptop poor performance. I have tested it now on intel core i7 client and achieved 285Mbit/s. It coud be more but i7 still is bottleneck:

speed: 285Mbit/s
client side cpu usage 95%  
server side cpu usage 14%

Greetrings. Kris

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.