2

I was about to install mongodb on Linux Mint 19.1 (Tessa) via .deb file but when I checked the packages to be removed, I found this:

Screenshot of changes required

To install the following changes are required:
To be removed: curl
To be removed: libcurl4
To be removed: php-curl
To be removed: php7.2-curl
To be removed: virtualbox-6.0
To be installed: libcurl3

Many packages I need are going to be deleted, is this true or is it a bug? Can I just ignore this and install mongodb?

  • 1
    Where did you get a mongodb deb? It is probably the wrong one. – Michael Hampton Jul 15 at 16:54
  • It looks like you are installing the package for Ubuntu 16.04, which requires libcurl3 (which conflicts with libcurl4). For Linux Mint 19 you should instead be installing the package for Ubuntu 18.04 which uses libcurl4. – Stennie Jul 15 at 19:59
  • @Stennie Thank you very much, you are so right! The right version has no problem at all. – DonBeto Jul 16 at 12:46
1

It looks like you are installing the MongoDB package for Ubuntu 16.04, which requires libcurl3 (and conflicts with libcurl4).

For Linux Mint 19.1 you should instead be installing the MongoDB package for Ubuntu 18.04 which uses libcurl4.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.