0

We've just been switched from ISDN to SIP. Since the guy who installed and configured the phone system does not have a lot of experience in setting up LAN networks, we need to do it ourselves. My knowledge of setting up LAN networks is also quite basic.

Our current setup is the following: enter image description here

Some of our configurations on our TP-Link router are the following:

WAN1
Connection Type: Static IP
IP: 5.10..
Subnet Mask: 255.255.255.0
Gateway: 5.10.. (IP of the ISP 1 modem)

WAN2
Connection Type: Dynamic IP
IP: 192.168.178.21
Subnet Mask: 255.255.255.0
Gateway: 192.168.178.1

System Mode: NAT

LAN IP: 192.168.111.1

DHCP: enabled

Bandwidth Control: disabled

Line Backup: no rules active

Rounting: Except for a few port forwardings nothing is configured

Router auto generated "Route Table":

Destination        Gateway         Flags   Logical Interface  Physical Interface  Metric  
------------------ --------------- ------- ------------------ ------------------- ------ 
0.0.0.0/0          192.168.178.1   GS      eth2               WAN2                 0       
0.0.0.0/0          5.10.*.129      GS      eth1               WAN1                 0       
5.10.*.0/24        N/A             C       eth1               WAN1                 0       
192.168.111.0/24   N/A             C       eth0               LAN                  0       
192.168.178.0/24   N/A             C       eth2               WAN2                 0       

Some of our configurations on our FRITZ!Box router are the following:

WAN: Auto setup through ISP

IP: 192.168.178.1

Subnet Mask: 255.255.255.0

DHCP: enabled

Routes & Port forwardings: none


What we want to achieve

The FRITZ!Box needs to be able to send and receive to/from the 192.168.111.* network, since on the clients there is a software installed to make and receive calls.

The clients should only be able to connect to the internet via ISP 1 only and therefore whit the IP 5.10...


What we noticed

The problem now is, that the TP-Link router uses the IP of ISP 2 most off the time. Since no load balancing or fallback is configured it should only use WAN1.

What also does not make any sense to me is, that although it seems that we access the internet via ISP 2 we do have the speed of ISP 1.


How can we achieve our goal?
If you need any further information, please let me know.

Thanks in advance!

  • Please edit your question to include the configurations of the router and Fritzbox. – Ron Trunk Jul 22 '19 at 12:14
  • Well, those are hundreds of single options. Are you looking for anything specific? – René M. Jul 22 '19 at 12:16
  • If there is a configuration file, please include that. Otherwise, include everything regarding IP addressing and routing. – Ron Trunk Jul 22 '19 at 12:20
  • I have added a few options. Most options one each router aren't set. – René M. Jul 22 '19 at 12:56
  • Also the config of the Fritzbox. – Ron Trunk Jul 22 '19 at 13:00
0
  1. Remove the first default route on the router:

    0.0.0.0/0 192.168.178.1 GS eth2 WAN2 0

  2. Add a default route on the FritzBox, with next hop of 192.168.178.21

|improve this answer|||||
  • Thanks for your answer unfortunately I cannot remove the route, because it's in the auto generated system rounting table. If I add the next hop of 192.168.178.21 wouldn't that mean, that the FRITZ!Box always connect via the TP-Link router to the internet? – René M. Jul 22 '19 at 14:37
  • If you can't change the configuration of the router, you will never be able to do what you want. And I thought you wanted the Fritzbox to use ISP1 as well. If that is not the case, you will add a route to 192.168.111.0 to the fritzbox (same next hop) – Ron Trunk Jul 22 '19 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.