0

I am mounting a directory, e.g., /home/docs/ from PCserver to PCclient using the SAMBA share in Linux. Both computers are in Linux (Ubuntu).

I perform sudo mount -f cifs with the necessary parameters, and everything works okay. The /home/docs/ from PCserver is mounted in PCclient. The problem is that the symlinks of the PCserver, either //files// or //directories//, are not mounted as symlinks, but as target files or directories.

How can I mount symlinks of the server als symlinks in the client, using samba?

I have tried in the smb.conf file the option follow symlinks = no. The only result is that folders als symlinks cannot be opened in the PCclient, but symlink files are mounted as the target files and not as symlinks.

I have found a similar question. But no clear solution is given.

1
  • Can you the output of mount | grep "/home/docs" executed on a client to your question. I guess this includes nounix or noposix or nolinux. You could try to mount with mount -t cifs -o ...,linux option, I did test this but did not succeed. Not sure if that is related to my setup. – Thomas Jul 22 '19 at 18:41
0

If both computers run on Linux, we can rather set up an NFS Mount (See how to set it up), instead of SAMBA. This mount respects the original symlinks as they are in the PCServer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.