1

I am having a problem with Apache 2.2 (httpd) conf files. I have it hosted on RHEL, and we have ldap URL which contains "$Customer" in the memberOf filter. Due to that, normal placement of ldap URL in double quotes results in wrong interpretation of the filter, as RHEL treats this as environment variable.

Applying single quotes to ldap string in conf file solves the issue, but conf files are handled/generated by xslt scripts which cannot be modified, so thats not the final option in our case, as manual fix will be required after each modification.

Is there any other way to escape dollar sign in Apache conf files?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.