1

I am experiencing an issue if I want to do a zfs receive on FresBSD 11.3. I start it using zfs receive -vF destpool@snap1 < snapshot.zfsdump. The sending part works fine but the receive says:

receiving full stream into destpool@2019-07-27

And then the whole machine is getting laggy. At first I can still use the mouse, but I cannot for example establish a new SSH connection into it. I also cannot abort the command in the terminal using crtl-C.

I have tried debugging it by looging at suspicious dmesg messages, but there was nothing. Also I tried recreating the zfs pool on the destination disk.

What I want to achieve is to backup my ZFS root system onto another pool in the same machine.

It seems similar to zfs send -i / receive stalling but this is FreeBSD, not Solaris and it has not fully investigated then, too.

I am grateful for any ideas.

Update I have made some more experiments. When receiving small datasets it works, however when I tried to transfer a 2 GB dataset the machine stalled again.

# zfs receive -vd zfsroot < /tmp/test.zdump
receiving full stream of zroot/tmp@2019-07-24 into zfsroot/tmp@2019-07-24
received 4.39MB stream in 1 seconds (4.39MB/sec)

The 2 GB snapshot did not finish.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.