0

I'm trying to install PostGIS extension on arch Linux. here tried so far as archlinux wiki about PostGIS :

sudo pacman -S postgresql-libs postgis
sudo systemctl restart postgres.service

and go to psql -d "dbName"

so for verifying the extention exists in postgres :

-- verify available extensions
SELECT name, default_version,installed_version 
FROM pg_available_extensions WHERE name LIKE 'postgis%' ;

it shows the tables . but when im trying to create extentions with these commands:

CREATE EXTENSION postgis;
CREATE EXTENSION postgis_topology;
CREATE EXTENSION fuzzystrmatch;
CREATE EXTENSION postgis_tiger_geocoder;

I get this error :

ERROR: could not load library "/usr/lib/postgresql/postgis-2.5.so": libproj.so.15: cannot open shared object file: No such file or directory

1

According to the following link you could be missing the shared object if you had previously uninstalled an older version of PostGIS after having already installed the newer version: https://github.com/OSGeo/homebrew-osgeo4mac/issues/574

Other than that, there are a few bug reports of postgis issues with certain versions of postgresql, so you should confirm you aren't running affected versions. Here are the results I was looking at:

https://www.google.com/search?q=usr%2Flib%2Fpostgresql%2Fpostgis-2.5.so&oq=usr%2Flib%2Fpostgresql%2Fpostgis-2.5.so&aqs=chrome..69i57j69i58.1247j0j4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.