I've setup client certificate validation in apache and it's working just fine. However I'd like to disable the client certificate validation on specific page.

Here's the config I use so far :

# Verify client certificates
SSLCACertificateFile /etc/my-webserver/ssl/CA.pem
SSLVerifyClient require
SSLVerifyDepth  1

<Location "/public">
    SSLVerifyClient none

The problem is that when trying to access /public I still get prompted for a certificate.

The official documentation gives an example on how to do the opposite (i.e. Only enable certificate validation on a specific page).

I was unable to find anything to anwer my problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.