1

I have a Windows Server 2019 instance on EC2 that had only one private and one public IP assigned to it.

I had to add more publics IP's to my domain and point to them. So I did:

Private and Public IP's

Elastic IP's

But now I'm not able to ping the new Elastic IP's assigned:

Ping Test

I'm able to ping only the primary IP (18.231.0.114)

Is there some extra config to do besides the private IP assignment?

Thanks in advance!

1
  • Adding an IP to an instance is part one, after than you need the operating system to recognise and respond to requests on those IPs. I've never had to do that and I'm not sure how, but knowing what needs to be done you can likely work it out. – Tim Aug 3 '19 at 8:08
0

You didn't describe what you've done on the Windows side, so the issue may be there. Getting Windows to recognize those additional IP addresses is somewhat involved. In a nutshell, you have to specify the IP addresses as static so that Windows can work with them.

If you haven't already done so, I recommend reviewing Configuring a Secondary Private IPv4 Address for Your Windows Instance. Notably, the instructions say to use the same private IP addresses that should normally get assigned by DHCP or it won't work properly.

1
  • Thanks a lot! Solved my problem. I did nothing on Windows side. It was with DHCP configuration. I'm new on AWS so I'm learning by doing. Setting the IPv4 to static and adding my private IP's solved it. All is working fine. Thanks again! – C. S. F. Junior Aug 2 '19 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.