0

I used to connect from home with Microsoft SSMS to a Microsoft Database. Can I do the same from SQL Workbench to an Aurora database?

I read this: https://aws.amazon.com/premiumsupport/knowledge-center/connect-rds-mysql-workbench/, but to me it's fuzzy about what I'm asking. And this page seems to requires a Cloud9 Environment: https://aws.amazon.com/getting-started/tutorials/configure-connect-serverless-mysql-database-aurora/

I found my public home IPAddress and added to a "Security Group". I added /32 on the end of my home IP address to make it a CIDR address. Then I modified my serverless Aurora database to allow that security group.

But I cannot connect even with Telnet myname.cluster-c900joynbtoe.us-west-2.rds.amazonaws.com 3306.

Later I found this, which implies it is not possible: ' https://docs.aws.amazon.com/AmazonRDS/latest/AuroraUserGuide/aurora-serverless.html#aurora-serverless.limitations

I do have an EC2 instance, I might try install SQL Workbench there and give it a try (using Remote Desktop/RDP) to connect to the EC2.

  • 1
    If in fact you have an Aurora serverless deployment, that link you included does say you can't do what you're trying to do. Notably, you could deploy Aurora differently (not serverless) in which case it should be no problem to connect to it remotely with the proper setup. – vjones Aug 4 at 23:10
  • I added the security group of the EC2, and I'm able to connect from there. Still cannot connect from home. I can connect to my Microsoft SQL database from home, so I think the IP address is properly setup. Cannot even Telnet to the Aurora server from home. – NealWalters Aug 5 at 0:05
  • 1
    If you set up Aurora in serverless mode, you can't connect to it from home. You can only connect to it from within the VPC. – vjones Aug 5 at 1:14
1

Amazon provides a "serverless" option when you set up an Aurora RDS database server. There are benefits to this, but one drawback is that you cannot connect to it from anywhere outside the VPC that it resides in.

It's possible you can work around this by tunelling over SSH. An alternative would be to set Aurora up in standard, not serverless mode. Then you should be able to connect remotely with the right Security group setup.

  • Any speculation on why that limitation? – NealWalters Aug 5 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.