Ubuntu 18.04
"KDE Plasma5 Workspaces" as desktop environment in Active directory
SDDM login screen


Ubuntu login screen default settings.

AD logins works and is fine. Is it possible to modify SDDM login screen to show empty username & pass or last AD username. By default it`s shows local username and not empty login or last AD user. User must click on Different User button every time to log in. Any idea how to modify greeter. Did try to google it with no success. Did try to install various themes it does not help.


Maybe there is other greeter more flexible so it can display empty fields? I did try lightdm with no sucess. Sure I`m missing something.

2 Answers 2


Assume your UIDs start at 10000 (not counting system users). The range from 10000 on is typically used for non-local users. Then the following in /etc/sddm.conf should help:


Note that UIDs of local users typically start at 1000, so if those also shall be hidden, then use MaximumUid=999.

You can also add


to this section to get rid of some more artifacts.

  • Unfortunately these settings have no effect. Aug 12, 2019 at 8:44
  • Is it still showing users with UID 10000 or greater? Aug 12, 2019 at 12:02
  • Actually this config works only not MaximumUid, but MinimumUid!!! Aug 13, 2019 at 7:11
  • Then I guess the relevant UIDs are below 10000 on your system. Did you check? Aug 13, 2019 at 7:21
  • I think the setting applies to specified user UID (from AD ) and they have UID way over 10000. So correct setting will be MinimumUid, but thank`s a lot Your suggestion helped. Aug 13, 2019 at 8:32

There seems to be a long-standing Fedora bug (from 2015 up until Fedora 30 this May) with a similar question:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.