1

I run:

sudo yum install steam

then I got this error:

file /usr/lib/firewalld/services/steam-streaming.xml from install of steam-1.0.0.61-2.el7.i686 conflicts with file from package firewalld-0.6.3-2.el7.noarch

The only solution that I found was removing firewalld but I dont want to do that. Does anyone know how to fix it?

0

The error occurs because the /usr/lib/firewalld/services/steam-streaming.xml file from the steam package is trying to replace an existing file from the firewalld package.

Where is the steam package downloaded from? When I look at the latest Fedora package for steam at https://fedora.pkgs.org/rawhide/rpmfusion-nonfree-x86_64/steam-1.0.0.61-3.fc31.i686.rpm.html, it does not contain the steam-treaming.xml file.

An earlier release has this comment

2019-01-18 - Simone Caronni - 1.0.0.59-5 - Firewall definitions already bundled in firewalld 0.6.2 on Fedora 29+. - Update firewall definitions to align with Fedora 29+.

If you are sure of what you are doing:

  1. Make a backup of /usr/lib/firewalld/services/steam-streaming.xml
  2. Download the RPM package for steam
  3. Install while replacing file

    sudo rpm -ivh --replacefiles steam-1.0.0.61-3.fc31.i686.rpm

  • Thanks it works now. – Cracker Aug 14 at 3:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.