I run:

sudo yum install steam

then I got this error:

file /usr/lib/firewalld/services/steam-streaming.xml from install of steam- conflicts with file from package firewalld-0.6.3-2.el7.noarch

The only solution that I found was removing firewalld but I dont want to do that. Does anyone know how to fix it?


1 Answer 1


The error occurs because the /usr/lib/firewalld/services/steam-streaming.xml file from the steam package is trying to replace an existing file from the firewalld package.

Where is the steam package downloaded from? When I look at the latest Fedora package for steam at https://fedora.pkgs.org/rawhide/rpmfusion-nonfree-x86_64/steam-, it does not contain the steam-treaming.xml file.

An earlier release has this comment

2019-01-18 - Simone Caronni - - Firewall definitions already bundled in firewalld 0.6.2 on Fedora 29+. - Update firewall definitions to align with Fedora 29+.

If you are sure of what you are doing:

  1. Make a backup of /usr/lib/firewalld/services/steam-streaming.xml
  2. Download the RPM package for steam
  3. Install while replacing file

    sudo rpm -ivh --replacefiles steam-

  • Thanks it works now.
    – Cracker
    Commented Aug 14, 2019 at 3:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .