0

I am trying to set up a 2 Node failover cluster using Windows server 2016. I deployed the servers in AWS. Here are the details.

I used ;

  • 1 server acting as the Domain Controller ( 10.30.10.101 ) installed a domain.(globex.local) 2 servers acting as nodes which are connected to the same domain.(NODE01, NODE02)

  • NODE01 - 10.30.10.102 NODE02 - 10.30.10.103

  • 1 server acting as the iSCSI file server. It also joined in the same domain.

  • I used one AWS region and one subnet (10.30.10.0/24) for deploying
    all my servers

Attaching the iSCSI disks are successful. Cluster Validation is also successful. But when I am going to create the Cluster, it stuck in the FORMING CLUSTER stage for a long time and gives me the following errors. I did a lot of research and I granted the domain administrators' permissions necessary to create cluster resource objects (computers). All the servers are in the same folder. While creating the cluster I can see it creates a computer with the same cluster name I gave. But it does not finish creating the cluster.

I struggled so hard to solve this but still no luck. Seeking for a solution.

I did a lot of research and I granted the domain administrators' permissions necessary to create cluster resource objects (computers). All the servers are in the same folder. While creating the cluster I can see it creates a computer with the same cluster name I gave. But it does not finish creating the cluster.

Specially, I remember when I tried to add NODEs, I only could add the local node by its netbios name. When I use the netbios name for remote node, it gives an error. I used IP addresses and then it worked. But in the tutorial videos I can see they add both NODES with their short netbios name. I am doubting if that is the problem.

I struggled so hard to solve this but still no luck. Seeking for a solution.

    Beginning to configure the cluster Cluster.

Initializing Cluster Cluster.

Validating cluster state on node NODE02.globex.local.

Searching the domain for computer object 'Cluster'.

Find a suitable domain controller for node NODE02.globex.local.

Check whether the computer object Cluster for node NODE02.globex.local exists in the domain. Domain controller \\GRI-DC.globex.local.

Bind to domain controller \\GRI-DC.globex.local.

Check whether the computer object NODE02.globex.local for node NODE02.globex.local exists in the domain. Domain controller \\GRI-DC.globex.local.

Verifying computer object 'Cluster' in the domain.

Checking for account information for the computer object in the 'UserAccountControl' flag for Cluster.

Validating installation of the Network FT Driver on node NODE02.globex.local.

Validating installation of the Cluster Disk Driver on node NODE02.globex.local.

Configuring Cluster Service on node NODE02.globex.local.

Validating installation of the Network FT Driver on node NODE01.globex.local.

Validating installation of the Cluster Disk Driver on node NODE01.globex.local.

Configuring Cluster Service on node NODE01.globex.local.

Waiting for notification that Cluster service on node NODE02.globex.local has started.

Forming cluster 'Cluster'.

Operation failed, attempting cleanup.

An error occurred while creating the cluster and the nodes will be cleaned up. Please wait...

An error occurred while creating the cluster and the nodes will be cleaned up. Please wait...
  • did you run the Cluster test fully? – djdomi Aug 14 at 19:48
  • yes. Validations tests are passed. But I cant move forward. – Zac Aug 14 at 19:52
  • Both Update to the latest and same stand, moreover did you try a clean restart i. e. checking that nö update etc is outstandinh – djdomi Aug 14 at 19:56
  • updated all the servers and all restarted. Validation is fully successful. But I am deplyoing this in AWS. It seems like theres a issue on NODE02. May be there a DNS issue. Do e have to change specific DNS setting when we use AWS? – Zac Aug 15 at 8:32
  • i dont know, ususally you setup dc, Set dns (dc) and ip static, and create the 2 kund and after that ususally the Cluster should work – djdomi Aug 15 at 12:55
0

I found the answer myself.

I went to,

Network Adapter Settings > Ethernet > Properties > IPv4 Properties > Advanced Tab > DNS > And selected "Append primary and connection specific DNS suffixes."

Default it was using AWS DNS suffixes and now, I could create the Cluster.

Hope this will help someone !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.