2

I have installed brotli on my apache server. The problem is Wordpress is not using brotli compression. It uses gzip only. I have turned off zlib.output_compression, disabled cdn and WP-Rocket but still its using gzip and not brotli. I have even tried adding rules in .htaccess. Nothing works. Please help

2
  • Brotli works only via https. Are you using https on your server/virtualhost?
    – x86fantini
    Commented Aug 15, 2019 at 22:01
  • Yes, I am using https Commented Aug 16, 2019 at 3:30

1 Answer 1

0

if you are using WP Rocket they add a bunch of .htaccess rules automatically and don't have a Brotli selector in their settings panel, they only support gzip, so check your .htaccess file for anything there about gzip. If you are using that plugin here is the related issue: https://github.com/wp-media/wp-rocket/issues/1524 probably other Wordpress cache systems have a similar issue about auto writing to the .htaccess and thus preventing brotli from working.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .