0

We want to migrate a Windows 2008 Foundation (HP Proliant ML110G7) to Windows 2016 Standard (Lenovo TS140)

Many sites state that Windows Server should be made in steps. So first one was to upgrade to Windows 2008 R2. Although seemed a problem at the beginning, it was easily accomplished by just downloading the last versión from Microsoft site and upgrading and activating (180 days license) We did not purchase a W2008 license since we won´t be using it.

At his point, two ways seems viable
1.- Migrate the HP Proliant server to the TS140 and continue upgrading it or
2.- Upgrade the current HP Proliant to W2012 (license purchased that barely will be used), then to W2016 (license also purchased) and then migrate to the TS140.

We opted for the first solution and here´s where we´re completely stuck.

We tried to sysprep the HP and also a BareMetal backup.

Sysprep stars to boot and configuring devices etc, but at the very end, states that it could not complete the installation. By the way, what is the difference between OOBE and audit mode of sysprep? We used OOBE.

BareMetal restores the disk without problem, but the server won´t boot. After restoring it, it just reboots and on the second one states that a system repair should be performed. Asks for the Administrador password (no typo, the server runs in spanish) and it doesn´t accept the actual (and correct password)

We´ve checked the questions here at ServerFault and all over the network and we´ve tried all the bootedit and bootrec solutions we´ve found and no one of them works. It seems that the boot partition of the (new) disk in the TS140 can not "see" the system partition.

Any ideas? Someone suggested to use a tool named AOMEI Backupper but we wan´t to exhauste all "in the box" ways and tools first

Update: Just for testing we tried to update the HP server to Windows 2012. No luck. It complained that it was a evaluation version and it should be activated with a full license before proceding. We found one on a very well known site (I don´t know if we can tell names here) We activated it but are still looking for ways to migrate it first to the Lenovo one and continue updating there.

Update: We used WinRE and inspected the BCD (Boot Configuration Data). We tried bootrec /RebuildBCD with no result. There is an entry in BCDs (resumeobject) that seems to be a GUID. It is a hard disk ID or something like that? We haven't found any information on this entry. If we let the server boot in secure mode it starts to do so but at some point, it just restarts.

  • 2
    What exactly are you migrating? Active Directory? Line of Business applications? What? – joeqwerty Aug 17 '19 at 2:06
  • The whole server joeqwerty. It has a long time fine tunning and many servers of all kind. It serves databases, web sites, email, etc. According to social.technet.microsoft.com/Forums/lync/en-US/… "You can use BMR(Bare Metal Recovery) for recovering your machine to same/different hardware by booting into WinRE using the Recovery Disk" – alvaroc Aug 17 '19 at 4:36
  • We also tried Clonezilla and got the same results as BMR – alvaroc Aug 20 '19 at 1:19
  • Biggest block to bare metal restore is you can't jump BIOS or disk partitioning schemes - for example from BIOS to UEFI or MBR to GUID, Though you can do BIOS to UEFI legacy compatibility mode. – Brian Aug 23 '19 at 20:13
  • It doesn´t seem to be the problem. The HP server has no UEFI and the TS140 has it but it is configured to legacy mode (and since it boots partially, the machine can see the boot disk. Is after that when things get ugly) – alvaroc Aug 26 '19 at 16:41
0

Boot in restore mode and try a fixboot.

At that point I would start to think to install a new OS and restore the data to the fresh OS.

If you have a systemstate backup of the 2008, please know that you need a fresh 2008 to restore it onto.

For your next time please remember that you dont have to get pirated keys. You buy a 2019, and you use your downgrade right option to be able to run whatever you need, even for a short time lapse and you can finish on the 2019 at the end.

  • yagmoth555. We have tried fixboot with no luck. Also a fresh install is not viable. The keys are all legal. That thing about downgrade seems very interesting. We'll take a look – alvaroc Nov 25 '19 at 18:38
  • @alvaroc As another option to restore, do you have a ESX locally ? as maybe running a bootable media for vmware converter, it would be able to mirgate and rebuilt the boot section to a ESX destination – yagmoth555 Nov 25 '19 at 18:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.