4

I'm trying to install XRDP and I'm hitting the following:

[root@box ~]# yum -y install xrdp
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: centos.serverspace.co.uk
 * epel: mirrors.coreix.net
 * extras: mirror.sov.uk.goscomb.net
 * updates: mirror.sov.uk.goscomb.net
Resolving Dependencies
--> Running transaction check
---> Package xrdp.x86_64 1:0.9.10-1.el7 will be installed
--> Processing Dependency: xrdp-selinux = 1:0.9.10-1.el7 for package: 1:xrdp-0.9.10-1.el7.x86_64
--> Processing Dependency: xorgxrdp for package: 1:xrdp-0.9.10-1.el7.x86_64
--> Running transaction check
---> Package xorgxrdp.x86_64 0:0.2.10-4.el7 will be installed
--> Processing Dependency: xorg-x11-server-Xorg(x86-64) = 1.20.4 for package: xorgxrdp-0.2.10-4.el7.x86_64
---> Package xrdp-selinux.x86_64 1:0.9.10-1.el7 will be installed
--> Finished Dependency Resolution
Error: Package: xorgxrdp-0.2.10-4.el7.x86_64 (epel)
           Requires: xorg-x11-server-Xorg(x86-64) = 1.20.4
           Installed: xorg-x11-server-Xorg-1.20.1-5.6.el7_6.x86_64 (@updates)
               xorg-x11-server-Xorg(x86-64) = 1.20.1-5.6.el7_6
           Available: xorg-x11-server-Xorg-1.20.1-3.el7.x86_64 (base)
               xorg-x11-server-Xorg(x86-64) = 1.20.1-3.el7
           Available: xorg-x11-server-Xorg-1.20.1-5.el7.x86_64 (updates)
               xorg-x11-server-Xorg(x86-64) = 1.20.1-5.el7
           Available: xorg-x11-server-Xorg-1.20.1-5.1.el7.x86_64 (updates)
               xorg-x11-server-Xorg(x86-64) = 1.20.1-5.1.el7
           Available: xorg-x11-server-Xorg-1.20.1-5.2.el7_6.x86_64 (updates)
               xorg-x11-server-Xorg(x86-64) = 1.20.1-5.2.el7_6
           Available: xorg-x11-server-Xorg-1.20.1-5.3.el7_6.x86_64 (updates)
               xorg-x11-server-Xorg(x86-64) = 1.20.1-5.3.el7_6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Now, I get that it's missing a dependency, however, it appears to be saying it requires xorg-x11-server-Xorg version 1.20.4.

It then continues to say version 1.20.1-5.6.el7_6 is installed.

From where I'm sitting, 4 is in the range 1-5 so I'm unclear what the issue is. They all seem to be for the right architecture.

Is 1-5 a version string in and of itself as opposed to a range, or -if not- what am I missing?

Solution: Thanks to @zigam's comment, here's a workaround:

Having the same issue, I installed manually archived xorgxrdp yum -y install https://archive.fedoraproject.org/pub/archive/epel/7/x86_64/Packages/x/xorgxrdp-0.2.9-1.el7.x86_64.rpm then yum -y install xrdp and it works

  • 1
    1.20.1-5.3.el7_6 == version 1.20.1 release 5.3.el7_6, there is no range – zigarn Aug 19 '19 at 12:35
  • @zigarn Thanks, that's a key detail I was misinterpreting. I had assumed it was a rollup bundle of some kind. – Basic Aug 20 '19 at 19:54
4

The version of xorgxrdp currently in EPEL was built against RHEL 7.7, specifically against (among other packages) the xorg-x11-server-Xorg package version shipped in RHEL 7.7, but you are running CentOS 7.6.

It is not currently possible for you to install this package, until CentOS 7.7 is released. EPEL does not generally keep older versions of packages, so there is no older version of xorgxrdp to fall back on.

The last word I have seen (from yesterday) is that CentOS 7.7 is expected out "likely some time between 29 August to 6 September 2019." If you want to get early access, you can enable the CentOS CR repo, where the packages will be staged for a week or so prior to release. They should land in CR "early next week". See the comments in /etc/yum.repos.d/CentOS-CR.repo for an explanation of this repo.


How I figured out that the package was built on RHEL 7.7? I saw that the dependency it required had a higher version than any you had available. Based on this I suspected that the package needed a later RHEL version, as I have seen this sort of thing happen before in the weeks between a RHEL release and the corresponding CentOS release.

To confirm it, I looked on my nearest CentOS 7.6 system and saw the version number of xorg-x11-server-Xorg there was the same as that you had installed, and when I looked on a RHEL 7.7 system I saw the version number there was the same as the one it wanted as a dependency.

| improve this answer | |
  • 2
    P.S. Sign up here for a free non-production RHEL subscription that gives you access to Red Hat's knowledge base and lets you subscribe up to 16 RHEL physical or virtual machines. – Michael Hampton Aug 18 '19 at 1:06
  • Is this supposed to be normal to have released package in EPEL depending on future package of unreleased CentOS version? – zigarn Aug 19 '19 at 12:54
  • These problems are not by design, but they do happen when version requirements of packages are this exact. EPEL is a RHEL repository. It works on CentOS by design, but CentOS has lag as it builds everything from upstream. – John Mahowald Aug 19 '19 at 17:07
  • Thanks for taking the time to go into detail, that explains a lot. – Basic Aug 20 '19 at 19:52
  • @JohnMahowald It's a pity EPEL can't hold on to previous versions long enough for CentOS to catch up. – Basic Aug 20 '19 at 19:59
2

Wanted to add this as a comment, but if you have the package installed on another machine you can copy it over and rpm install it. If this is a production environment maybe look at setting up your own local mirror that keeps a certain number of package releases, unlike EPEL which only keeps the latest. This is a pretty silly situation and I ran into the same exact problem.

| improve this answer | |
  • Good tip, thanks. Unfortunately I don't in this instance (I'm in the process of setting up a disposable browsing environment, so one VM I keep (re)creating). Nothing else I use has xrdp installed. – Basic Aug 20 '19 at 19:52
  • 4
    Having the same issue, I installed manually archived xorgxrdp yum -y install https://archive.fedoraproject.org/pub/archive/epel/7/x86_64/Packages/x/xorgxrdp-0.2.9-1.el7.x86_64.rpm then yum -y install xrdp and it works – zigarn Aug 21 '19 at 9:51
  • That worked without a hitch for me, thanks @zigarn – Basic Aug 25 '19 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.