0

I want to migrate the domain service from goDaddy to AWS. I'm an absolute beginner, please be aware of that and be considerate. Here's what I've done and what hasn't worked.

  1. I purchased a domain name example.com at goDaddy.
  2. I also have an EC2 instance running with the security settings all in place, an apache server running on it and an index.html file in the var/www/html folder. It seems to work fine when I open http://ec2-my-elastic-IP.eu-central-1.compute.amazonaws.com in my browser (don't know what the technical term is for this? is it a domain name?)
  3. Then I created a new hosting zone at Route 53, named example.com
  4. I created an A record pointing to my elastic IP for the EC2 instance. It has a TTL of 600 seconds and no Alias. The routing policy is simple and the name is simply empty, i.e. @.
  5. This didn't work. So I tried to make sense of the record data from the goDaddy site. Unfortunately it doesn't come in the BIND format, which could be imported into Route 53. Instead they supply a file which looks like this (replacing the numbers with xxxx):
; SOA Record
example.com.    3600     IN     SOA nsxx.domaincontrol.com. dns.jomax.net. (
                    xxxxxxxxxxx
                    xxxxxx
                    xxxx
                    xxxxxxx
                    xxxx
                    ) 

; A Records
@   600  IN     A   Parked

; CNAME Records
www 3600     IN     CNAME   @
_domainconnect  3600     IN     CNAME   _domainconnect.gd.domaincontrol.com.

; MX Records

; TXT Records

; SRV Records

; AAAA Records

; CAA Records

; NS Records
@   3600     IN     NS  nsxx.domaincontrol.com.
@   3600     IN     NS  nsxx.domaincontrol.com.
  1. I tried converting this into the BIND format online without success. So I tried to create the records in the Route 53 environment that appear to be missing, namely two CNAME records. From the above file it looked like goDaddy has two CNAME records (I don't know what they do). Also within the Route 53 UI I didn't know which routing policy to select and whether I should select alias for those CNAME records, so I chose the simplest settings. After waiting for 24 hours, no website appears under example.com, just a blank page. I also created another A-record named www for the subdomain www.example.com (also pointing at the elastic IP from my EC2 instance). Nothing.
  2. Then I read this. It suggest that I should manipulate the DNS records at goDaddy, to update the four new name servers from AWS. But I can only edit the A and CNAME records and doesnt allow me to change the NS records.
  3. This question suggests to wait for 24 hours, but I did that a couple of times without success.
  4. This doesn't help, because I have no problems with my emails (yet), simply because I'm not bothered by that yet.

1 Answer 1

2

You'd need to change the NS records at the registrar, not within the zone on the current name servers. The information on the zone should match the glue records at the TLD. The glue records typically have higher TTL values, so it might take up to 48-72 hours to update them.

As a side note, the @ doesn't equal empty, but the base name specified with the $ORIGIN directive. Your zone is missing the directive, but that's not necessarily a problem, because...

If an $ORIGIN directive is not defined - BIND synthesizes an $ORIGIN from the zone name in the named.conf file.

2
  • Dear Esa Jokinen, thanks a lot for your quick reply. The registrar is goDaddy, so I followed their instructions on how to change the NS records. Let's keep the fingers crossed. Don't know what glue records are, and the entire DNS resolution process is a big mystery for me (name servers, records, TTL, resultion, etc) but I'll get there slowly but surely. Thanks! I'll keep you posted. I guess I have to also add at least an A-record at the Route 53 UI. Do I need to have any CNAME records in place as it was written in that file (see above)?
    – Marlo
    Aug 18, 2019 at 14:23
  • 1
    Yup, it works. I changed the NS records at the registrar and it works :)))
    – Marlo
    Aug 18, 2019 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.