I'm encountering a strange Exchange issue I haven't been able to figure out.

  • Exchange Online (Office 365).

  • Originally was an Exchange 2010 environment, migrated via O365 Hybrid Config, hybrid has since been decommissioned and the organization is cloud-only at this point.

Problem - It appears that I have several 'orphaned' public folders. Get-MailPublicFolder lists numerous public folders that don't appear in the output of Get-PublicFolder.

Get-PublicFolder -Recurse |Where-Object{$_.MailEnabled -like "*true*"} returns 11 results.

Get-MailPublicFolder returns 37 results.

The mail-enabled public folders that aren't returned by Get-PublicFolder don't display in Outlook or in the EAC.

If an email is sent to them, an NDR is returned stating the recipient cannot be found.

I compared the attributes I could see in Get-MailPublicFolder between one that is missing and one that does appear, and saw only one difference that I thought relevant - HiddenFromAddressListsEnabled. Contrary to what I would expect, the value for that was set to TRUE for the PF that WAS visible, and the attribute on the missing PF was set to FALSE. While this seemed the exact opposite of what I'd expect I went ahead and changed the attribute on the missing PF to TRUE to match the functioning PF. That made no difference.

I also noticed the 'SimpleDisplayName' attribute was null. I added a value to that, still no difference. (SimpleDisplayName is null on the working PF as well.)

What can I do to get my missing MailPublicFolder to be listed by Get-PublicFolder and displayed in my EAC? And if that isn't sufficient, to get the folder to receive emails sent to it? Clearly there is some disconnect somewhere preventing EOL from seeing this public folder, and I expect that the proper fix will resolve all of the various problems stemming from its invisibility.

Thanks, Steve


Are those invisible public folders belonging to the same public folder mailbox?

Firstly, you can try the following methods:

In outlook, you can try to disable cached Exchange mode. There is a similar case for your reference.

In EAC, you can use Get-PublicFolderClientPermission -Identity "\My Public Folder" -User xx | Format-List to check user permissions. For more details:Get-PublicFolderClientPermission

In addition, the problem described on NDR likes be caused by the public folder mailbox, you need to check if the mailbox is working properly.

  • Any updates? Have your issue been solved? Have my suggestions been feasible? – Joy Zhang Aug 27 '19 at 9:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.